WEMO Application

Showing results for 
Search instead for 
Do you mean 
Posts: 1
Registered: ‎10-07-2017

Re: 2 WeMo devices won't connect to Google Wifi router

[ Edited ]

Definitely a pain to setup my new wemo mini with Google Wifi.  My old wemo smart plug was just fine.  The new mini has the exact same issues as described above by JeffB.


I've tried uninstalling the app, unplugging my two other google routers so that only the master one is plugged in, rebooting my Pixel Phone with no luck.  Next is to reboot the main router but the family is watching a movie and I don't want to kill it.


I shouldn't have to go through all of this just to get a smart plug working on my network.


edit: Got it working after 2 hours of troubleshooting.  After everything above I tried rebooting the main router (did not work), a couple dozen other reboots, unplugged my older wemo devices (did not work), drained 80% of my phone battery with all of the constaint wifi connecting and disconnecting throughout the setup, and finallt read about someone using an older phone of theirs to complete the setup.  I went an grabbed an old Galaxy S6 and it ran through the setup right away!  


What a pain Belkin/Wemo!!  Please make this a better experience.  The second Google starts making their own I'll be switching.

Posts: 1
Registered: ‎11-13-2017

Re: 2 WeMo devices won't connect to Google Wifi router

[ Edited ]

I have the following scenario:


Google WiFi with three wifi points. 3 Echo Dots. 1 Echo. 


All echos working and 1 Wemo coffee makler and 1 Wemo plug working. I was installing 5 Wemo dimmers and 3 wemo switches. After adding a dimmer, I was able to see the dimmer in the wemo app. Alexa was unable to find the dimmer though. I could see that the dimmer was on the 2.4  band. So, I was concerned this was going to be an issue. 


I rebooted the echos - nothing.

I rebooted each wifi point - nothing.

I disabled the wemo skill in Alexa and reenabled - this worked! (And, it saw my previously added wemo devices without re-adding)


So, the issue is between Alexa and Wemo (Alexa can't easily pick up wemo inventory for whatever reason)

Posts: 1
Registered: ‎12-05-2017

Re: 2 WeMo devices won't connect to Google Wifi router

i created a guest network through google wifi app and it finally connected first try. 

Posts: 2
Registered: ‎02-03-2018

Re: 2 WeMo devices won't connect to Google Wifi router

I have followed that article as well. Did not resolve the issue.
Posts: 1
Registered: ‎04-03-2018

Re: 2 WeMo devices won't connect to Google Wifi router

"Contact the manufacturer" .. that is the default solution from Wemo.  I am flabergasted, I have the same issue and I would imagin most people with the mesh wifi has this situation.  Why doesn't Wemo post the solution?   For me, that switch just sits on the shelf, I don't want to bother Google with this question.   If Wemo doesn't care about customers who use one of the premier and most secure wifi solutions, then Wemo simply doesn't wish to serve that market.


If the solution is so clear and simple with a call to Google and Wemo won't take a few minutes to post the solution, than I simply will never buy another Wemo (or Belkin for that matter) ever again.   .... and I will gladly spread the word.

Posts: 43
Registered: ‎08-22-2017

Re: 2 WeMo devices won't connect to Google Wifi router

Hello, jrbvt.


We'd like to check on this with you. Have you tried to check the wireless security on the router if it is set to WPA2 Personal? Also, make sure that the Wemo devices are connected to the 2.4GHz network. 


Contacting the manufacturer would also be best, as there might be settings on the router that we can't be able to change and only your manufacturer knows.


You can also refer to this article for additional reference in troubleshooting.

Coleen_ 21984
Wemo Technical Support
Posts: 1
Registered: ‎06-03-2018

Re: 2 WeMo devices won't connect to Google Wifi router

I had the same problem. Two hours of trying to get a WeMo dimmer to connect to my network.

my router is an older dlink.

after trying all suggestions with no success, I noticed the channel was set to "6"  in my router setup. (I had done that years ago)

i enabled the auto selection for channel in the router and the WeMo setup ran perfectly.


This may be the problem with newer mesh networks, I suspect WeMo is trying to connect on a specific channel.

Posts: 1
Registered: ‎12-19-2018

Re: 2 WeMo devices won't connect to Google Wifi router

Goolge mesh wifi and Pixel 3 owner here with all sorts of Wemo gear in my house (multiple outlets, both on/off and dimmer light switches) that only sets up on 2.4 GHz networks. I did get my wemo stuff set up using some of the help here (thank you to the useful comments, no thanks to the useless folks who are likely paid by Wemo/Belkin to troll the user base here with useless "you must be an idiot"-style comments). 


Here's what I did (repeating some prior steps with all due credit, and trying to put it all here in one spot for folks):

  1. Put Wemo device into network connection mode (this varies by device but wemo does provide directions for that for each device. It's usually a combination of button pushes and holds to get the indicator light blinking and into connection mode.
  2. Now wait for a good 2 minutes. It seems to take forever for these Wemo devices to power cycle and get into connetion mode. Nothing will work until it's fully in that mode and you won't see your device show up in the wifi list of devices until it's completely run through it's long startup process.
  3. Open my Pixel and go to the wifi screen where you would select a wifi network. Click on the name of your mixed network (I use Google mesh wifi router so it all has one name, even though the wifi router uses both 2.4Ghz and 5.0Ghx). When you click on the network it brings you to a screen where you can "forget" your network (don't do that!) and it shows things like signal strength and frequency. This is the key info for the next steps. I hope that it's not just my Pixel that shows this (b/c it has the latest edition of Android), but that you can see this also. 
  4. While checking on both signal strength and frequency, walk outside with your phone (no kidding, you need to get away from the strong but short-range 5.0GHz signal and into the range where your phone will only "see" the 2.4GHz network) and go around 50 feet from your house/apt/whatever. You should see your signal strength Excellent or High at first and your Frequency will say "5 GHz", but that strenght will drop as you walk away, and at some point (for me it was ~50 feet) the frequency will change from 5 to 2.4GHz. Ah-ha! Stop there. You might even be able to walk closer to the house now that you have connected to the 2.4GHz signal, but at some point it will switch back to the 5GHz so don't go too far back. 
  5. At that point, once it's on 2.4GHz, you can go back to your phone's main Wifi screen (the one that lists all of the wifi networks it can see) and wait for a few moments for the list to show all of the 2.4GHz points in its purview. You "should" now see your wemo device listed. It will have "wemo" as part of the wifi name.
  6. At this point you can now select the Wemo device as if it's actually the wifi access point you want b/c that's what you need to do to get the setup going. Then you can launch the Wemo app and it will guide you through adding your new device. Note that throughout this process you need to stay where you are b/c if you get this far and then walk back into your house it will switch over to your 5GHz network and won't be able to authenticate the new Wemo device on your 2.4GHz network, which is definitely a part of their whole setup process.

I hope this helps someone out there.

Posts: 1
Registered: ‎12-31-2018

Re: 2 WeMo devices won't connect to Google Wifi router

Thank you so much!!! I follow your steps and now ALL my Wemo devices are connected to my Google WIFI