WEMO Application

Showing results for 
Search instead for 
Do you mean 
Posts: 11
Registered: ‎01-01-2018

2 -year- struggle, works with nest still not working

So for the past 22 months i have been fighting my wemo light switch and my nest thermostat. Trying to get the Wemo to work correctly has been impossible.


I have the works with nest all sorted out and the Wemo app can see the nest, but does not update status correctly. It stays in whatever mode it is in and I can't force a temp or home/eco mode change. Rules to turn on my light switch on Nest home won't work.


I can use the Nest app perfecty, no issue with the thermostat and IFTTT sees the nest perfectly. Wemo has no idea what is going on and I am about had it.


Tech support has been saying they have no idea for the past 2 years every few months I try again with someone new to see if they had any ideas. Nope. I get past 1st level support and then always miss their phone calls and they never answer mine.


Now, I am all for digging into this myself... obviously if I didn't send this back to them in 100 pieces already. Does anyone know of any way I can snoop the Wemo status signals or something to see what Nest is sending to it, and what the Wemo actually sees?


Wemo support says they have no way to see any status or changes, so I really don't know what else to do or look at.


I'm not averse to learning scripting or networking or whatever else, if theres a way I'll keep at it. Smiley Happy



Posts: 170
Registered: ‎12-12-2017

Re: 2 -year- struggle, works with nest still not working

Hey mistermog, you seem to have done most of the troubleshooting for your devices. Allow us to endorse you to our Product Experts to assist you with the advanced troubleshootings steps. There may be some configurations you might have missed.


Please shoot as an email at WemoCares@belkin.com together with your contact details:

Full Name:

Email Address:


Phone Number:

Community Username:

Along with a link to this post for reference.


We look forward to receive your email.

Wemo Technical Support
Posts: 11
Registered: ‎01-01-2018

Re: 2 -year- struggle, works with nest still not working

I've already done that and have been emailing (with no response in a month now) support@belkin. I'll do it again tonight though.

I did find something yesterday that made some progress. I removed the physical switch from the wall and when I reinstalled it, I also did a factory reset. On the light switch.

Now when I go into the app, nest updates perfectly as it should in the app. Now the only thing that doesn't work is the nest home away rule. Time rules turning on and off the switch work fine.

I've removed the rule and deleted the app and reset it all, nest rule still doesn't work.

Anyone know of a way to see the status and communication on television switch itself?
Posts: 11
Registered: ‎01-01-2018

Re: 2 -year- struggle, works with nest still not working

By the way, I did find this in another thread here, wondering if this is true. If so, I will request that Belkin/Wemo give me a refund for the 2 years of time I've wasted when no one has mentioned this.


"I wanted to follow up on the ticket that is open under your name. I understand you are unable to get the Wemo to work with your Nest Home. This can be attributed to the fact that Belkin discontinued the feature after Nest renamed the Auto Away feature with the Eco feature"


Again, as of now this is hearsay, but will try to get a hold of someone to ask.



Posts: 4
Registered: ‎04-10-2019

Re: 2 -year- struggle, works with nest still not working

Hello, I've been having the same issue. Thermostat sometimes shows up in teh Wemo app.. the Nest Home / Away rules sometimes works, etc..

After three lengthy call with Wemo support, they told me Wemo no longer support the Nest Home / Away rule..


HOWEVER afer doing some more troubleshooting, I've found that it was an issue with the Wemo app trying to allow different wifi networks to control it.


If you have your Wemo mini plugs set up on your 2.4 GHz wifi network (which you should have to, as they cannot use 5 GHz), you must set up your Nest thermostat on the same network AND add your Nest account (after enabling remote access in the Wemo app) using the same 2.4 GHz network.


This allowed me to use the Nest Home / Away rules accurately.

I can access the Wemo app using Cellular network, but I cannot use it using the 5 GHz network.. As soon as I do, it seems to deauthorize the Nest account, and lose the thermostats. i used to be able to control the Wemo app no problem on my 5 GHz network at home, it may have started after the most recent app update..


Hope this helps!