WEMO Application

Showing results for 
Search instead for 
Do you mean 
Posts: 1
Registered: ‎02-01-2019

Android app 1.22 Rules not accessible without location?


I recently purchased 2 wemo smart plugs, and had a terrible experience setting up rules in the android app..

I could set up the rules, and everything looked good, but nothing would actually happen at the event time.

No shceduled on then off, no vacation mode, and even the countdown timer was not working


I Googled, and found several posts suggesting things like updating firmware, clearing files and reinstalling android app, installing app in different devices, etc all leading up to call this number for assistance. I tried them all except the phone call, because I figured there had to be an answer out there somewhere. After several hours wasted I came across a single post from someone who mentioned that his or her solution (strange as it sounds) was to change his location in the app from the small town she or he lived in to a larger city nearby. I thought no way this is going to work, but I tried it anyway, and low an behold it actually worked...

This "Fix" has been working perfectly for the last month and a half so I'm inclined not to mess with it.


Along comes Android Version 1.22

I updated my 32bit Oreo phone to the new version of the app, only to find out that now the app now requires location to be turned on in order to indentify my netowrk correctly (even though it was able to before). I denied access because I don't want the app to update my location, and break my rules, but now everytime i try to go to the rules tab on the app, the app just hangs there with the wheel spinning saying looking for rules so I can not view or change any of them. I tried clearing my data and reinstalling the app to no avail.


So my questions...

Is the app supposed to behave like this? (no access to rules with location off)

If I turn location on will it update my location in the app, or will it just be used to identify my netowrk?

Is or was there a fix in the works for this small town bug (timers not working until I changed my location to a big city)


Thanks in advance for any tips or suggestions.