WEMO Application

Showing results for 
Search instead for 
Do you mean 
Posts: 1
Registered: ‎05-15-2018

App is closing after last update

I've been using 3 Wemo Switch F7C027 whihc have been working very well for severl years.
Yesterday evening when I opend the App on IOS I got a message there was an update. I ran the update and since nothing is working anymore. 
All plugs can't connect to my WLAN, the orange LED doesn't stop to blink.
I reset them and tried to reinstall them again. Once the Switch selected in the WLAN settings, I start to set up my WiFi network and once I enter the password the App closes. I tried to deleted and reinstalled the App but it's still the same.

What could be wrong? How could I make them to work again?

Posts: 126
Registered: ‎12-13-2017

Re: App is closing after last update


Hello Dav09,



Make sure that the app is up-to-date. Also, you may try using a different handheld device and try if you can access the Wemo devices. For verification, what's the LED status of Switch? How far are the Switches from the router?

Reynaldo - 22029
Wemo Technical Support