WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 3
Registered: ‎03-02-2019

?Conflict with WhatsApp on IOS?

For several monthsI've noticed that my Wemo devices at times disappear from the IOS App.  Refreshing does not fix this, however sometimes rebooting the phone does fix it. It appears to effect the Mini Plugs most, but can also effect Switches.

 

I started looking at whether any of the open apps might be causing the problem.  I think I have narrowed it down to WhatsApp being open on my iPhone.  If I close that app and wait a few minutes, the Wemo devices reappear in the Wemo app and I can use them OK, no phone reboot needed.

 

Has anyone else seen this issue?

 

I am using an iPhone 7, with all latest IOS, App and Wemo firmware installed.

 

 

Thanks,

 

Pat

Moderator
Posts: 60
Registered: ‎12-12-2017

Re: ?Conflict with WhatsApp on IOS?

Hello @ptainter. Do you mean to say that your Wemo devices do not appear on the Wemo App's device list? Or it only shows as "Not Detected"? What's the behaviour of the LED if the setback occurs? Does any of your devices prompt with any updates before you noticed this concern? Please let us know, and try to check if the same issue appears using a different handheld device.

Elyza – 22075
WEMO Technical Support
Posts: 3
Registered: ‎03-02-2019

Re: ?Conflict with WhatsApp on IOS?

When I open the Wemo App, the devices are listed, sometimes grayed-out (just like they have been disconnected) and sometimes they look normal until I touch one to turn it on, it will then gray-out and ask me if I want to hide the device until it reconnects.  It only seems to do this when the WhatsApp app has been "open" in the background for some time on my iPhone.  If I then force close the WhatsaApp app and wait a few minutes, the missing devices will reappear and work OK in the WEMO app.

Moderator
Posts: 12
Registered: ‎02-12-2019

Re: ?Conflict with WhatsApp on IOS?

@ptainter. What’s the iOS version your iPhone is running on? Try to uninstall and reinstall the app and reboot your iPhone and check if that improves anything. Isolate the issue by using a different handheld device and run the WhatsApp app in the background and check if it will do the same thing.

 

 

Zane-2248

WEMO Technical Support

Posts: 3
Registered: ‎03-02-2019

Re: ?Conflict with WhatsApp on IOS?

I'm running IOS 12.1.4 (16D57), but this started a few months ago after udating to v 12.

 

I uninstalled the app, rebooted and reinstalled it.  All has been good for 3 days now.  I think the problem is now solved.

 

 

Thanks for your help.