WEMO Application

Showing results for 
Search instead for 
Do you mean 
Posts: 1
Registered: ‎10-04-2018

Device can't connect to main network but can to guest network?

Recently changed my router from an Apple Airport over to Netgear Orbi. Overall I'm loving the wifi speed all over my house, but one thing is driving me crazy...


I have three Belkin WeMo switches - two are connected to the main (as in, not guest) network just fine so I can control them from my phone, but one absolutely will not connect to the main network, but will happily and reliably connect to the Orbi guest network. This is a pain because the WeMo app will only allow remote control of the devices on the same wifi network.


I would be raising this issue over on the WeMo forums if it wasn't for the fact that it connects without any issue whatsoever to the guest network (confirmed by seeing its MAC address in the device list inside the Orbi admin interface).


I have tried everything I can think of to get it working, including...


  • Making sure the Orbi firmware and WeMo firmware are all up to date (they are, all 3 WeMo switches running the same firmware)
  • Making sure I factory reset the WeMo properly
  • Trying to connect to the two identical versions of my main network that show up in the list in the WeMo app during setup (I guess it is seeing the main Orbi unit and satellite separately, I had a similar issue with two cheap IP cameras but gave up on getting those working!) - I wondered if the satellite only broadcast in 5GHz or something, which the WeMo doesn't support
  • Trying to figure out if the device is somehow blocked on my Orbi setup for some crazy reason (I didn't have much luck with that - the Orbi admin interface showing my devices seems very buggy as mentioned in other posts - some wireless devices show as wired, some supposedly 'blocked' devices are actually connected fine - it seems something to do with how you name devices and the web interface not correctly parsing HTML characters)

I am at a loss - I guess I could buy a replacement WeMo and see if that does the trick, but the fact that I can see the **bleep** thing on my guest network (and tested at a separate household and worked fine) makes me blame the Orbi. It also worked just fine on my Airport network.


Can anybody think of anything else I haven't tried? Thank you fine community Smiley Happy

Posts: 167
Registered: ‎12-12-2017

Re: Device can't connect to main network but can to guest network?

Hi jhamond987,


You can try to temporarily disable the Guest network and reconfigure the Wemo device to see if it will connect to your main network.

Jan - 22019
WEMO Technical Support