WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 1
Registered: ‎04-03-2019

Multiple failures with WeMo Apr 2019

I bought my WeMo in February 2019 through Amazon, and when I first got it everything worked as advertised: Rules, remote control, etc.

Then I kept the device in my drawer for about 2 months, and now that I really need it, I notice it's not working as before:

- I've reset the device both from app and physically

- I've deleted all data both in the app and in my phone, and reinstalled app several times with same results

- I can't enable remote access, it always says it's not possible at this time and try later

- I create rules and they appear active, but they take no effect: It doesn't turn on/off at the specified time.

- I can't set up my current city. It used to show me cities matching the name as I typed it, now it just doesn't.

- Because of the previous point, I can't create sun rise/set rules.

- Sometime when I open the app and look at rules, I see some rules I created days ago.

 

In short, all I have is a device that turns on and off touching the touch-sensitive button at the front, and that's not what I thought when buying this product. I've seen posts saying WeMo cloud was restored in late March, but for what I can see, it's dead to me.

 

Unfortunatelly my time to ask for a refund in Amazon has expired. Very dissapointed.

Moderator
Posts: 403
Registered: ‎08-08-2017

Re: Multiple failures with WeMo Apr 2019

Hi samuelmolina. Allow us to look into this further. Have you tried setting up your WEMO device with a different compatible handheld device/s? Make sure that they are running on their latest OS version/s. If it still won't work, please send us an email at WemoCares@belkin.com so we can have our 2nd Level Support Team check on your case. Please include providing us the following:

 

-Phone Number
-Location
-Model Number of the WEMO device
-Serial Number
-Community Username
-Link to this post for reference

Jo-Ann - 21744
WEMO Technical Support
Posts: 1
Registered: ‎04-04-2019

Re: Multiple failures with WeMo Apr 2019

I have been using wemo for 5 years and after changing my ssid and updating iPhone to 12.2 iOS I can’t access my 10 devices!!! Need assistance ASAP!
Thanks
Moderator
Posts: 15
Registered: ‎02-18-2019

Re: Multiple failures with WeMo Apr 2019

Hi @knosalaa.

 

Since you've done any changes on your SSID, you have to reset and re-configure your Wemo devices.

Here's the link that can help: https://www.belkin.com/us/support-article?articleNum=8010.

 

 

Regards.

 

 

Juviena_P 22245

Wemo Technical Support

Posts: 9
Registered: ‎03-30-2019

Re: Multiple failures with WeMo Apr 2019

I've reset and reconfigured my devices, and they still don't work with Alexa! Your app works sometimes, but my Alexa device does not recognize them. Seriously, since you're update about a week or so ago everything is going all screwy. What the hell is going on? I even emailed your support staff, and nobody has replied. This is really starting to piss me off!