WEMO Application

Showing results for 
Search instead for 
Do you mean 
Posts: 306
Registered: ‎06-29-2015

Re: New router, WeMo app won't find switches

@LMJ1229 There are various reasons why Remote Access to your WEMO would be disabled. It could be that your Wemo device is no longer connected to the internet or it has lost power. If you'd like to work with us and help you resolve the issue, e-mail us the following info so we can forward your case to our 2nd level Support Team:


• Full Name: 
• Phone Number:
• Location (state/country):
• Model # of Wemo Device:

• Link to this Community Post:

• Community Username:


We'd appreciate your patience and cooperation.

Dennis - 20702
WEMO Technical Support
Posts: 1
Registered: ‎05-28-2017

Re: New router, WeMo app won't find switches

I spent 90 minutes with Belkin tech support today because I am having all of the issues above ... but we just kept resetting one switch and trying to get remote access to work ... we messed with ports on the router ... we reinstalled the app (iOS and Android) ... she made me call my cable provider (because she said they had to be blocking it -- they replied that nothing was blocked, and I actually found the controls for the modem and confirmed that.)

Right now everything is working -- as long as I don't use the Belkin Apps -- I've pretty much given up on getting it to work and successfully enable remote access.  (Allegedly my firmware will never update without this?)

Interesting that there are many, many threads with similar complaints ... I only joined this one because it seems to be one of the most current.

Posts: 5
Registered: ‎07-19-2017

Re: New router, WeMo app won't find switches

This is because all wemo products are utter crap. Changed my router password and cannot re connect my 3 insight switches, wasted 3 hours trying to connect. Now have thrown them all away, utter amateur hour crap delivered by rubbish product managers
Posts: 1
Registered: ‎08-12-2017

Re: New router, WeMo app won't find switches

I was having this exact same problem with one of the older (larger) WEMO switches after I replaced my router with a Netgear ORBI mesh system UNTIL I tried this (i.e. adding the "Force Stop" and "Clear Cache" steps (#3 on the list below) on my Android phone to those provided by Belkin.  


Before I added this step, all would proceed as advertised but when I clicked on the switch in my phone app the "button" would swirl yellow for a couple of seconds and then the switch icon would be grayed out.


After adding the force stop/clear cache step it worked.  And FYI I had also previously tried uninstalling and reinstalling the phone app with no success.

@doctor_klahn wrote:

In case anyone else has come looking for answers (like myself). Here is the mystery proceedure I had to figure out in order to get all of my LIGHT SWITCHES to reconnect to my new router:

1. Hit power restart.
2. Hold reset until green/orange flashing.
3. Open WEMO app info. Force stop and clear cache; close app.
4. Open wifi list and connect to the switch you have in reset mode.

5. Reopen WEMO app and pray it will connect on the first try. If it does not, go back to step 3.

6. Rinse and repeat one switch at a time.

This was the only solution that worked for me after reading and trying just about every suggestion here. We're talking days worth of beating my head against a wall, nearly ready to rip them all out before I accidentally found a viable solution.

App is the latest version on Android Nougat. 


Posts: 1
Registered: ‎10-15-2017

Re: New router, WeMo app won't find switches

I had a similar problem.  I have 2 Wemo Insight Wall Outlets and 2 Wemo WIFI switches.  Due to some Xfinity Comcast slow intenet issues, I turned off and turned on my Cisco WIFI router regaining my plan bandwidth, but causing me to lose connection to the 4 Wemo devices on my Wemo app on my iphone.  After trial and error did'nt work, I reinstalled the Wemo app on my ipHone.  I could not find a button how to "reset t factory" on my WIFI switches, to I went to the Wall Outlets, removed them, pressed the pin button on top, plugged it in, and waited for change, then released.  One of the devices then showed up on my iPhone Wifi. I connected.  Then opened the app and it found "Wemo.Insight.16" and I connected. Renamed it as before and took a picture and saved.  Then on refresh all my devices showed up in the App as connected.  Althugh the problem was solved, I lost my historical data on average power, costs, and usage on the clean installed device associated with Wemo.Insight.16. 


Hope this helps,



Posts: 2
Registered: ‎07-05-2018

Re: New router, WeMo app won't find switches

We switched internet providers and got a new modem/router as a result.  (also changed from cable to DSL) Although the NEST found the new WIFI network (had to then enter password of course) the WEMO switch (exterior lights controlling) didn't.


I tried the usual troubleshooting, switched modem on and off, reinstalled WEMO app a few times, etc.  Nothing worked.  Thanks to this site I then pressed the reset button on bottom of switch and WEMO finally appeared on our WIFI network. My husband took off the switch plate initially where he found instructions to press and hold reset button for 5 seconds, then press restart. However, if you know this ahead of time no need to remove switch or cover plate.


Also, the reset and restart buttons on our WEMO switch very tiny and hard to see at bottom of switch in same white colour.  Hope this could help someone else with this problem.