WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 12
Registered: ‎03-11-2016

Not able to save rule on Android

Running latest app.

 

When I try to save a new rule it just spins...

 

I've tried killing the app, Force Stopping, uninstalling/reinstalling no luck...

 

Any ideas??

Moderator
Posts: 555
Registered: ‎06-17-2015

Re: Not able to save rule on Android

Hi, @ScottChapman. What the WEMO app version? Can you tell us the make/model and the version of the Android device that you are using?


Have you tried to set up the rules by using another mobile device?

Thaddeus - 14850
WEMO Technical Support
Posts: 12
Registered: ‎03-11-2016

Re: Not able to save rule on Android

Running version 1.14 (looks like it was updated march 6th?) on Lollipop

Posts: 12
Registered: ‎03-11-2016

Re: Not able to save rule on Android

Oh, I did install on my other android device running Marshmallow. And it didn't show any devices at all...

Expert
Posts: 200
Registered: ‎06-30-2015

Re: Not able to save rule on Android

Let's further isolate this, ScottChapman. We suggest doing the following:

  • Go to Settings and select App info. Look for the WEMO app.
  • Tap on Clear cache and clear data.
  • Uninstall and reinstall the WEMO app.

Perform these steps on both of your Android devices. By the way, were you able to successfully save the rules before? 

Kristine_14845
WEMO Technical Support
Posts: 12
Registered: ‎03-11-2016

Re: Not able to save rule on Android

I actually did the stop app/ clear data & cache on my tablet (which is able to see the devices). I have never created a rule before.

 

On my phone (marshmallow) it is a little more cumbersome. It doesn't immediately go to looking for devices, instead it tries to walk me through setting up new devices. During which it gives me some message about wifi auto-scan. But the corresponding instructions do not seem to apply to Marshmallow (the setting to look for in advanced wifi don't appear to exist on my Nexus 6P).

Moderator
Posts: 306
Registered: ‎06-29-2015

Re: Not able to save rule on Android

Thank you for trying that out, ScottChapman. For further isolation, please perform the following:

 

  • Reset the Switch
  • Force close the WEMO app
  • Reboot both your android handheld devices

Once done, try to run the WEMO app again on both handheld devices seperately and check if you can now detect your WEMO. If you still can't, please email us your complete contact details at WEMOCares@belkin.com together with the link to this community thread and your community username for our reference. 

Dennis - 20702
WEMO Technical Support
Posts: 12
Registered: ‎03-11-2016

Re: Not able to save rule on Android

Thanks. I'll do that tonight.

 

But, how can I get the app on my marshmallow devices to show my devices? Like I said, right now it assumes I was to setup devices, and there doesn't appear to be a way to tell it to just show me what is already on my network.

Moderator
Posts: 340
Registered: ‎06-15-2015

Re: Not able to save rule on Android

You can try the same workarounds we've posted, ScottChapman. By the way, is the firmware of the WEMO device/s up to date? You can post them on this thread so we can check it. If they are not updated, it is possibly causing this challenge.

Irish_16855
WEMO Technical Support
Posts: 12
Registered: ‎03-11-2016

Re: Not able to save rule on Android

So, I reset one of my switches and my marshmallow tablet saw the device and let me configure it.

 

WHen it was done it still shows no devices.

 

My lollipop tablet which was showing all devices now shows all devices EXCEPT the one I set up.

 

Firmware versions are WeMo_WW_2.00.1062.PVT-OWRT-LS