WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 100
Registered: ‎05-28-2014

Re: Post 1.9 update, 2.00.7166.PVT, sunset rule doesn't fire.

The situation appears to be isolated with your WeMo devices. How many handheld devices have you used to test the WeMo sunset rules? What are there OS versions? You might wanna try Phillip's suggestion about trying the Sunset rules via IFTTT and check if it will work. Either way, this should be reported to Belkin support.

Posts: 15
Registered: ‎09-17-2014

Re: Post 1.9 update, 2.00.7166.PVT, sunset rule doesn't fire.

After deleting the app and rules, and then re-adding both, my wemo's seem to be working fine.

Posts: 100
Registered: ‎05-28-2014

Re: Post 1.9 update, 2.00.7166.PVT, sunset rule doesn't fire.

Good thing removing and re-installing the Apps worked for you, dopealope. Are the Sunset/Sunrise rules triggering on time?

Posts: 5
Registered: ‎11-03-2014

Re: Post 1.9 update, 2.00.7166.PVT, sunset rule doesn't fire.

[ Edited ]

[quote]

 I haven't done any testing as yet but at the moment my suspicion is that the turn off time as set is being adjusted by the margin that is set on the sunset time. For example, if I have a switch set to turn on at 30 minutes less than sunset and off at say 11pm, then the off time appears to be adjusted down by 30 minutes. As I have all switches set to different margins I will have to do more testing. Lodging a support request with Belkin just returns the same old reply, delete and reintall app etc, etc! I have done that several times, no change! [/quote]

 

I have come to exactly the same conclusion. My light is set to turn on 2 hours before Sunset, and off at 11pm. It comes on at sunset fine, but then turns off around 9pm. Bit of a coincidence then both of us are experiencing turn off by the same amount as the offset.[/quote]


Someone has made a mistake with the firmware, - just need Belkin to actually fix it.

Posts: 12
Registered: ‎10-25-2014

Re: Post 1.9 update, 2.00.7166.PVT, sunset rule doesn't fire.

[ Edited ]

markhewitt1978 wrote:

 

Someone has made a mistake with the firmware, - just need Belkin to actually fix it.


There lies the problem! I have had responses from support, I have said I have my suspicions that there is

a problem with this firmware, but I always get the same response, delete/reinstall app, reset Wemo's etc etc

I don't know how many times I need to do it before I convince them it is not my setup but their crap firmware!

Posts: 223
Registered: ‎05-24-2014

Re: Post 1.9 update, 2.00.7166.PVT, sunset rule doesn't fire.

[ Edited ]

markhewitt1978 wrote:

[quote]

 I haven't done any testing as yet but at the moment my suspicion is that the turn off time as set is being adjusted by the margin that is set on the sunset time. For example, if I have a switch set to turn on at 30 minutes less than sunset and off at say 11pm, then the off time appears to be adjusted down by 30 minutes. As I have all switches set to different margins I will have to do more testing. Lodging a support request with Belkin just returns the same old reply, delete and reintall app etc, etc! I have done that several times, no change! [/quote]

 

I have come to exactly the same conclusion. My light is set to turn on 2 hours before Sunset, and off at 11pm. It comes on at sunset fine, but then turns off around 9pm. Bit of a coincidence then both of us are experiencing turn off by the same amount as the offset.[/quote]


Someone has made a mistake with the firmware, - just need Belkin to actually fix it.


I agree that it is probably with the firmware. Belkin must've been doing something to see what is happening. Have you tried creating the same rule using another handheld device? This will help in isolating the situation. 

Posts: 9
Registered: ‎10-23-2014

Re: Post 1.9 update, 2.00.7166.PVT, sunset rule doesn't fire.

markhewitt1978

 

 Belkin definitely has a problem/software fault to correct.

 

My experience is simiar with two WEmo Insight wall switches that are up to the latest firmware rev level. It looks like they shut off about 2 hours early. I have them turning on at 15 minutes before sunset. They used to work correctly.

 

I should add that, although the app indicates that the rule is still active, the switches are, in fact, off

 

Best Regards,

 

John H.

Posts: 12
Registered: ‎10-25-2014

Re: Post 1.9 update, 2.00.7166.PVT, sunset rule doesn't fire.


jholmblad wrote:

markhewitt1978

I should add that, although the app indicates that the rule is still active, the switches are, in fact, off

 


Same here

Posts: 5
Registered: ‎11-03-2014

Re: Post 1.9 update, 2.00.7166.PVT, sunset rule doesn't fire.

I did a simple experiment with my wemo plug.

 

I set a rule to put the light on 30 minutes before sunset, and switch off at 8.00pm

 

As suspected the light turned off at 7.30pm.


I changed the rule so it turns on at exactly sunset, and off at 8.00pm. And it turned off at 8pm.

 

So it's definitely the issue that the firmware is confusing the offset from sunset with the turn off time and applying it in both places. It's nothing to do with DST and resetting the device won't help.

 

The clincher is that Belkin support have said "As a workaround, set the rule to turn off 22:00 and it should turn off at 20:00. "

 

So it seems like they know about it.

Posts: 38
Registered: ‎10-22-2014

Re: Post 1.9 update, 2.00.7166.PVT, sunset rule doesn't fire.

I have an idea for a workaround until there is a proper fix.
I had an ON UNTIL rule that switched on 10 minutes before sunset and switched off at 22:30. Since the firmware update my rules has been switching on correctly but switching off at the wrong time. The rule even says its active even after the switch has gone off. So to me it appears that the switch is calculating the on duration incorrectly.
My hopefully short term work around is to have 1 rule that is just on ON rule triggering at 10 minutes before sunset. I then have an OFF rule triggering at 22:30
Not an ideal solution but it seems to be doing the job.