WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 2
Registered: ‎02-28-2019

Rule Time/Timezone off by +1 Hour

I have a total of ten WEMO devices, one Light Switch, one Insight Smart Plug, and eight Mini Smart Plugs. They are all on the latest available Firmware WeMo_WW_2.00.11057.PVT-OWRT-LS, WeMo_WW_2.00_11057.PVT-OWRT-InsightV2, & WeMo_WW_2.00.11299.PVT-OWRT-SNSV2.

 

The location in the WEMO app is correctly set to 'Whitby, Ontario(CA)', which oddly changes to 'Whitby, CA' once saved. This is in the EST timezone. The time on my iPad & Android Pixel 2, which I have been using the Wemo app with, is correctly set.

 

Some of the devices have Rules configured to automatically turn them on and off, e.g., the Light Switch at the Front Door, aka 'Front', is programmed to turn on at Sunset (exact, no offset) and with a separate Rule to turn off at 10pm. A similar rule exists for the Mini Smart Plug 'Living Room'.

 

Those Rules used to work fine, but I have recently noticed that those Rules are now getting executed exactly an hour after the expected time. Yesterday, Sunset time at my location was at 6:01pm, but both of those devices turned on at 7:01pm. Similar with the 'off' Rule, e.g., it was meant to execute at 10:30pm, but it happened at 11:30pm sharp. I have security video proof with a time stamp of it happening.

 

I have contacted WEMO via Twitter (@WEMOCares). The first response had a good idea about the offset with the Sunset/Sunrise Rules, but not thought through, because it does not apply to the exact time off Rules also having the same issue. Afterwards, I have only gotten the advice to reinstall the app and reset the devices. I have done that ('Erase All Content and Settings'), which is a very annoying task, but it did not solve the problem.

 

My WiFi Router and the WEMO devices have all been rebooted by giving the whole house a temporary blackout and flipping the main switch.

 

I see some older posts that have the same issue. Some seem to have been caused by being away with the controlling device in another timezone, but this does not apply to me. Even if the controlling device was in another timezone, the location that was set for the devices should be used to determine the correct one.

 

Is there some way to check what time/timezone the WEMO devices are set to? In a second step, what could lead to them getting changed?

Moderator
Posts: 12
Registered: ‎02-12-2019

Re: Rule Time/Timezone off by +1 Hour

@StephanCanada,

 

Try these steps in isolating the challenge:

  1. Select a totally different city
  2. Force-close the Wemo app and reopen
  3. Set the city back to its original location
  4. Observe if it improves anything

 

 

Zane-22248

WEMO Technical Support

Posts: 2
Registered: ‎02-28-2019

Re: Rule Time/Timezone off by +1 Hour

@Zane_T,

 

I tried your recommended steps.  Afterwards, I created a new Rule to be executed ten minutes later for a test and it got executed on time, but a day later, I am back with the same issue, e.g., the Front Light Switched turned on an hour too late again. It’s like that the location/time zone synchronization is not making it to all devices.

 

Yours,

Stephan

Highlighted
Moderator
Posts: 301
Registered: ‎08-22-2017

Re: Rule Time/Timezone off by +1 Hour

@StephanCanada

 

Hi there! If the same thing happens when recreating the rules with another handheld device(s) and synchronizing the router's time on the controlling device, let's have our Escalation Engineers look into this further by sending an email to WemoCares@belkin.com. Please include the following details so they can further assist.

  • Full name.
  • Phone number. 
  • Community Username.
  • The link to this post for easy reference. 
Carl_S 21985
WEMO Technical Support