WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 23
Registered: ‎05-20-2015

Rules is a giant mess

[ Edited ]

So, I had to disable 3 rules at the beginning of December. I looked for them when I wanted to enable them again yesterday and they are nowhere to be found. Okay, so it was only 3 rules so I decided to just redo the 3 rules. I found the Wemo switch then I create the rule, saved it and... and it doesn't even show up in my rules! It's nowhere to be found. Honestly, I dont think I have ever seen a worse app. It works sporadically and then not at all. There is always something wrong with it. It's just terrible. I called support in... I don't know... India? And they were like "Is the light blinking?" "What are the serial numbers of your switches?" It was pretty clear that they were trying to cover the fact that they had no idea what to do.

Posts: 275
Registered: ‎03-08-2017

Re: Rules is a giant mess

So rules are definitely broken. Someone managed to deduce a workaround through trial and error. Delete any long press rules you have for any of your devices, create the rules you want to add, and then set up the long press rule again.
Posts: 23
Registered: ‎05-20-2015

Re: Rules is a giant mess

[ Edited ]

Thanks, airmandan, I was wondering if others were having the same problem. I do not have any long press rules so not much I can do to work around it. I hope Belkin gets this fixed quickly, although I am skeptical to say the least.

Posts: 5
Registered: ‎08-30-2017

Re: Rules is a giant mess

Try turning your wifi off on your phone and using a cell connection. I have a similar problem and I can work around it that way. After you make your changes to your rules you can turn wifi back on.
Posts: 23
Registered: ‎05-20-2015

Re: Rules is a giant mess

[ Edited ]

Thanks JW - Turning off the wifi helped, in that I could see all my devices but when I make a on/off rule it saves but it's nowhere to be found in my rules. When I try to make the same rule again, it tells me I'm duplicating a previous rule. The whole thing is very screwed up.

Posts: 23
Registered: ‎05-20-2015

Re: Rules is a giant mess

So, I checked the 3 devices last night and it seems the rules are working - they are going on and off as I set them - it's just that I cannot see them in the list.

Posts: 110
Registered: ‎12-11-2014

Re: Rules is a giant mess

I am having the same issue, many of my rules are missing from the app but they all seem to be executing properly. I do not have any long press rules at all either.

Posts: 23
Registered: ‎05-20-2015

Re: Rules is a giant mess

[ Edited ]

Exactly. I have 12 devices and can see only 4 rules. Wonder is Belkin is actually doing something about this problem? I hope the WeMo Bridge will bypass the horrible WeMo app and work correctly with Apple HomeKit. That would be a breath of fresh air after enduring the lousy WeMo software.

Posts: 1
Registered: ‎01-18-2018

Re: Rules is a giant mess

BELKIN,

There is a SERIOUS bug in the app!  Only four rules display in the app, even though there are more configured, and there is no way to scroll down to the remaining rules.

 

The only way to edit an existing rule is to delete rules until the rule I want to edit is showing, then edit the rule, then recreate the rules I deleted.

 

Please fix this bug and release an update QUICKLY! This is very inconvenient!

Posts: 23
Registered: ‎05-20-2015

Re: Rules is a giant mess

It's crazy, right? You'd think this being a MAJOR screw up, Belkin would be working night and day to fix it but that has never been the case with them. Their software development folks are awful. It's funny how their WeMo Bridge sold out in a day or two and they have to backorder them. I suspect because everyone hates the app so much that they are willing to fork out the $40 to use WeMo with Apple Homekit, which I'm sure will be better.