WEMO Application

Showing results for 
Search instead for 
Do you mean 
Posts: 95
Registered: ‎08-08-2017

Re: Unable to save rules

@josephbuda wrote:

I am having the same issue.  I can control the switch via the app but cannot modify the rules when on my home network and the rule will not run.  I have had the switch for 3 years now with no issues.  I changed ISP and it was working for about 3 weeks then hasn't now for the past 2 weeks.   I recently updated the firmware.  Tried to reset the switch and reconnect everything.  That didn't work.


When I open the app from an outside network (work) I can modify the rule and see the device and control it on and off.  Can't tell if it's running though.  What could be the issue?

Have you tried using a different handheld device to isolate the issue? If the issue still persists. Please email us at WemoCares@belkin.com so we can have this taken care of by our 2nd Level Support Team for further diagnosis along with the following details:

  • Phone Number
  • Location
  • Username
  • Link to this Community thread for reference
Wemo Technical Support
Posts: 1
Registered: ‎05-24-2014

Re: Unable to save rules

I have been unable to create rules for months. I've tried all the suggestions within this discussion. I currently have 4 dimmers, 11 switches, 1 maker, and 2 minis. I currently have zero rules, as resetting all devices and starting over cleared any existing rules I had from when I only had a couple devices.


Primary device: OnePlus 3T, Android 8.0.0

Secondary device: Samsung Galaxy S8, Android 8.0


Both devices are running the latest app version. All Wemo devices are running the latest firmware.

Posts: 162
Registered: ‎08-08-2017

Re: Unable to save rules


Have you tried creating the rules when you are connected via mobile or cellular data? If you have, please reach out to us at WemoCares@belkin.com along with the details requested by so we can have our Support Team check on your case further.

Jo-Ann - 21744
WEMO Technical Support
Posts: 2
Registered: ‎04-03-2018

Re: Unable to save rules

I've done everything, reset everything, uninstalled and reinstalled everything, updated everything, deleted rules, turned off wifi and I've got like15 off these. The problem lies in the application, not anyof my hardware. This needs a web based application that works.
Posts: 149
Registered: ‎08-09-2017

Re: Unable to save rules

Make sure that you're on the latest firmware. BTW, email us directly for further assistance. Please include the required details as per advised.

Pamela - 21733
WEMO Technical Support