WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 1
Registered: ‎06-10-2018

Re: WEMO Light Switch-Unable to join network

[ Edited ]

I had the same problem.  I turned on and off the power several times, uninstalled app and nothing worked.

 

Finally, I discovered there are 2 tiny, almost hidden, buttons on the lower part of the switch.  On the lower left is:

  • WI-FI Reset button

on the lower right is:

  • power restart button

If you hold the wi-fi reset button for 30 seconds or longer all the saved settings, including the wi-fi settings will go back to factory default, effectively forgetting all the WI-FI settings.

 

You will then be able to connect to the light switches own mini wifi with your phone.

 

It creates it's own mini wifi for the first 30 seconds or so after powering on, known as the "admin wifi".  You have to connect to it in order to then set up your connection from the switch to your home wifi.  Until you connect administratively with the app the switch won't be able to change any settings to your home wifi (this was due to my having upgraded my home wifi router and network settings that had changed).

 

This article describes how to reset to factory defaults
http://www.belkin.com/us/support-article?articleNum=8035 

there's a page on their site that details some of this, although not quite as explicitly as what I've outlined here.


http://www.belkin.com/us/support-article?articleNum=8183
wemo-belkin-light-switch-picture.JPG

Attached is the picture

 

 

Highlighted
Posts: 1
Registered: ‎05-07-2018

Re: WEMO Light Switch-Unable to join network

I had the same problem this morning.  The solution was to delete the wemo device from the wemo app and readd it back.  It worked like a charm.