WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 3
Registered: ‎03-08-2015
Accepted Solution

WEMO WiFi Keeps Dropping Out Before Setup Complete?

I just finished reading WeMo Reconnect on SSID Change or Reset

 

Understood that a Factory Reset is not exactly intuitive...  but I have made it happen a few times.

 

But nobody mentions a problem with the WeMo device's WiFi getting dropped.

 

I'll stumble through and finally get the WeMo.Switch.159 on my Android device's list of WiFi hotspots and I will connect the Android device to it.

 

But then, when I hop over to the WeMo app, it seems to be connecting to WeMo.Switch.159, but never gets through it's setup process - reverting to a connection to the WAP right next to the WeMo Switch.    

 

FWIW all 3 devices (Android, WeMo, and WAP) are within 12 inches of each other during the problem setup.

 

Also, the Android device's "Switch to best network" setting is disabled.

 

Anybody been here?

Community Manager
Posts: 558
Registered: ‎05-27-2014

Re: WEMO WiFi Keeps Dropping Out Before Setup Complete?

Hi PeteCress,

 

Check this article again, we just updated it a couple weeks ago.  It looks like there is another setting in Android that was intermittently causing issues during setup with some phones.  http://www.belkin.com/us/support-article?articleNum=110936

 

There is an always scanning feature that was causing the phone to lose connection as well as the Auto Network Switch option.

 

If that doesn't help you can forget the network on your Android device for that WAP and that should keep it from switching.

 

Regards,

Robert S.

Belkin Technical Support

Posts: 3
Registered: ‎03-08-2015

Re: WEMO WiFi Keeps Dropping Out Before Setup Complete?

[ Edited ]

That option is not availabe on my 1st generation Note... but there seems to be an analogous option in the WiFi Manager app... and I do have it turned off.

 

Tangentally: can anybody describe the *exact*, *precise* steps involved in doing a Factory Reset for the F7C027?   I've looked and looked for an F7C027-specific manual or user guide but came up empty.

 

"Press Reset for 5 seconds" does not count.... there is no "Reset" button on this thing.   I am guessing that the "Restore" button serves that purpose, but it's not happening for me....

 

That being said, I've managed to get into the magic mode (where it comes up on my Android device's list of WiFi hotspots) at least three times..... but I cannot replicate it at will.   I think I'm stumbling in to the right sequence/combination of actions but not realizing it.

 

Maybe come combination/permutation of Restore, the power button, and the right color blinking light?

 

 

Community Manager
Posts: 558
Registered: ‎05-27-2014

Re: WEMO WiFi Keeps Dropping Out Before Setup Complete?

[ Edited ]

Hi PeteCress,

 

  1. Unplug the unit
  2. hold the restore button down
  3. plug unit in while still holding restore button down
  4. count to 15
  5. release restore button and allow 45-60 seconds for it to become ready (blink amber/green)

I recommend counting to 15 due to the differences in the way everyone counts.  


Regards,

Robert S.
Belkin Technical Support

Posts: 3
Registered: ‎03-08-2015

Re: WEMO WiFi Keeps Dropping Out Before Setup Complete?

[ Edited ]

FWIW, on my device there is no Green light.   Only Amber and Blue.

 

Other than that, the Factory Reset procedure seems to work - at least I was able to replicate it 3 times in a row.

 

But here is the sequence of events:

 

Android: Connected to wemo

 

WeMo:  Switch.159 is now connected

      ("Remember Wi-Fi Settings = True)

      (user clicks Proceed)

 

WeMo: Connected to.... 159

      Attempting to connect, Please wait

      Attempting to connect, Still working

      Connected to Shed ("Shed" is a nearby WAP on my home network)

      Attempting to connect, please wait

      Attempting to connect, still working

      (multiple repetitions of above while showing "Connected to Shed")


      We've lost connection with the WeMo device. Please quit
      this app, reconnect to the WeMo network, and reopen
      this app.

 

Android: (user goes back to WiFi listing,  finds WeMo.159 no longer present)

 

 

So it seemed to come back to something like you initially pointed at: the Android device is dropping the

WeMo connection in favor of another device.

 

Next thing, I made all my routers and WAPs unavailable to the Android device - either by unplugging them or telling Android to forget their PWs.

 

Then I ran through the process again.

 

This time, after awhile WeMo said something like "Unable to connect, please exit, connect to your home network, and start the WeMo app again.

 

That did the trick.    When the WeMo app came up, it thought about things for a few seconds and then found the Switch.159 and I was able to turn the switch on-and-off from the WeMo app.

 

Bottom line, it looks like your observation was on the mark - except for the WeMo.Switch.159 dropping offline for no apparent reason and that a little extra action was needed to work around the problem.

 

Case Closed....

 

 

Thanks.

Community Manager
Posts: 558
Registered: ‎05-27-2014

Re: WEMO WiFi Keeps Dropping Out Before Setup Complete?

I have seen things like that where the WEMO connects to the network and finishes setup, for some reason the App doesn't get the message, does that exact behavior you mentioned.  

 

Glad to hear it was resolved though.

 

Regards,

Robert S.
Belkin Technical Support

Posts: 2
Registered: ‎03-15-2015

Re: WEMO WiFi Keeps Dropping Out Before Setup Complete?

I'm having a very similar problem with a Wemo Maker (ID number: 273) that I just purchased. I'm using an iPhone 5s running iOS 8.1.3 and the latest version of the WeMo app. The WeMo network shows up and I'm able to connect to the WeMo maker. I fill out the configuration parameters (toggle, sensor=no, email address, remember wifi settings) and click proceed. It then tries to connect to the wireless network, seems to succeed, and then the  wificonnection between the iPhone and WeMo Maker drops, but the Maker never shows up on the list of devices.

 

I've now reset the WeMo Maker to factory three times and repeated the steps above.  Same behavior each time. Suggestions much appreciated.

Community Manager
Posts: 558
Registered: ‎05-27-2014

Re: WEMO WiFi Keeps Dropping Out Before Setup Complete?

HI agt24,

 

I'm lacking a bit of information but it sounds like the maker is connecting to the network and just taking a long time for the App to find it.  If the maker is not on the network it is going to blink amber to signify as such.

 

I have seen things like this happen before where the WEMO connects but the App doesn't detect it.  The App knows it should be there but it cant see it so you usually get a blank device list.  If you have a dual band router make sure you are on the 2.4ghz band with your phone.  

 

Regards,

Robert S.

Belkin Technical Support

 

 

Posts: 2
Registered: ‎03-15-2015

Re: WEMO WiFi Keeps Dropping Out Before Setup Complete?

Thanks for your reply, Robert.

 

I also have a WeMo Insight Switch configured on the iPhone. I got it back in December 2014 and had no problems.

 

I have a Linksys E1200 which appears to be single band (2.4 GHz).

 

I just reset the WeMo Maker and walked through the configuration steps this time using an android phone (a Galaxy Note II) and had no problems getting the WeMo Maker configured. This is sufficient for me as I plan to control the WeMo exclusively through IFTT.

 

Thanks again for your help.

Posts: 1
Registered: ‎03-19-2015

Re: WEMO WiFi Keeps Dropping Out Before Setup Complete?

After months of seamless wemo insight switch use , one day they dropped out and now won't reconnect to my wifi . Same problem , goes through the whole setup until it's time to find wemo devices....then time out! Help. I have the iPhone 6