WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 1
Registered: ‎01-07-2018

WeMo Mini setup hangs at "Discovering your WeMo devices"

[ Edited ]

I'm having issues trying to set up a new WeMo Mini smart plug with the iOS app.

 

I have a dual band router broadcasting two separate 2.4Ghz and 5Ghz networks named "Love Shack 2.4Ghz" and "Love Shack"

 

I am able to connect to the WeMo network and initialize the setup just fine. It sees my 2.4Ghz wifi network with full bars (it's plugged in right next to the router). When I enter the password it ostensibly is able to connect to the wifi network because the app moves into the "Discovering your WeMo devices" stage. It hangs there for a while before displaying the error "We've lost connection with the WeMo device. Please quit this app, reconnect to the WeMo network, and reopen this app." When I power the WeMo switch on and off the light starts flashing amber which the troubleshooting guide indicates means it is unable to connect to the wifi network.

 

Hard resetting by holding the power button down when I plug the switch in lets me try again but I always end up in the same place. I would appreciate any help in troubleshooting my setup.

 

Thanks.

Posts: 1
Registered: ‎01-07-2018

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

Same problem. Anyone know what to do
Posts: 1
Registered: ‎01-07-2018

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

Same issue here.

 

I had a Mini that worked for three months, then would not recognize the network. Got a replacement and that will not recognize the network at all. I have the EXACT issue you have -- just an endless loop of asking for the password over and over, with the router not five feet away.

No amount of resets of the Wemo or the router helps. I'm not sure whether going to a lesser level of security than WPA2 would help -- I already had to shorten the password to 15 characters on the previous device -- but I'll be damned if I drop my security to help with a Belkin problem.

I bought two of these things based on the Belkin reputation. One is out of the return period, but I can still send the second back to Amazon. best I can do on the other is to leave a warning review.

Moderator
Posts: 290
Registered: ‎08-08-2017

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

Hi, All. Have you tried uninstalling and re-installing the WEMO App? For isolation, have you tried configuring it on a different handheld device and check if the same behavior happens? Make sure that they are on their latest OS version. If the issue still persists, please email us at WemoCares@belkin.com so we can have our Support Team check this with you. Please include providing us the following:

 

Phone Number:
Location:
WEMO App version:
OS version of handheld device:
Community username:
Link to this community post:

Jo-Ann - 21744
WEMO Technical Support
WEMO Maker Inventor
Posts: 1,701
Registered: ‎06-14-2014

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

Hmm, I can't be arsed to go check previous days, but I notice that EVERY ONE of your (belkin support) updates today were against customer posts that were exactly 10 days old.  I can't believe this is a coincidence.  What a spectactularly foolish support policy.  it certainly speaks volumes and perhaps explains the poor quality and usability of the wemo app and the poor dev process that allows so many regression bugs.

 

I guess I can anticipate a response to this post.  See you in 10 days.

Posts: 1
Registered: ‎03-31-2018

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

It is now March 31, 2018.  Just installed a new router to replace old one and the belkin/wemo nighmare for me has begun.  I get the exact same thing discribed in this thread.   After 1 hour of trying it with 3 of my 6 WeMo devices I then spent 45 minutes with a WeMo tech and we could not get past the problem.  Once we got to the 'lets restart your router" I knew we were going down a path of desperate.  Finally gave up.   Probably moving to SmartThings which will not have this problem since they use their own hub and not WIFI.

 

Did anyone ever find a solution to this?

 

Thanks

Highlighted
Posts: 1
Registered: ‎03-31-2018

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

Saturday, March 31, 2018

Same. Exact. Problem. Stuck in the very same place as previous commentators. Followed *every* troubleshooting procedure on Belkin’s site. And I, also, have two that *used* to work. So I set them up before successfully (it was a pain, but they *did* work). Clearly, Belkin’s reputation has really gone downhill.
Posts: 1
Registered: ‎05-16-2018

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

Just wanted to say ME TOO. Exact same problem. 2 months now. I try and then I give up and a few weeks later, decide to be optimistic only to waste my time with another epic wemo fail. So sad, because I really used to be a BIG fan.
Posts: 1
Registered: ‎05-29-2018

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

Are you by any chance using an Asus router? I had issues with my Sonos that went away after I disabled "airtime fairness" on the professional tab in the wireless section. Tried reconnecting my Wemos and they work like a charm again. 

Acr
Posts: 2
Registered: ‎06-01-2018

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

Same problem. Bought in on Amazon, it arrived today, and carefully stepped through the setup process. Over and over, each time it hangs at “discovering your wemo devices” then a “lost connection”, etc. Each time I reset to factory settings message, etc. I’ve spent 10 minutes playing with this. Tomorrow it goes back to Amazon and will be rated accordingly.