WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Acr
Posts: 2
Registered: ‎06-01-2018

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

 
Posts: 1
Registered: ‎06-30-2018

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

I've wrestled with this same problem and was able to fix it.

 

For some reason these devices don't get along well with wifi networks that have special characters in the network name. For example "Sam's Wifi Network" can create problems because of the apostrophe. If you have anything other than numbers and letters in your network name (and maybe even wifi password), I'd try renaming it and see if that fixes it.

 

I'd additionally make sure your smart switch is connected to a 2.4 Ghz network. It is my understanding that Wemo mini smart switches only support 2.4Ghz networks and not 5Ghz so that could also be your problem.

 

I've had my fair share of problems with these things but following these two rules has helped with my devices. Hopefully they should get your's working as well!

Posts: 1
Registered: ‎08-01-2018

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

For my wemo mini the special character solution does not help. I have no special characters in the SSID or the password.  I just think the product is hopelessly flawed.  Tried two devices, I got one device to work for 24 hours, that was it.  I have removed and reinstalled the app at least 6 times.  Reset the device at least two dozen times. It's a POS.  Never buy a wemo.

Moderator
Posts: 188
Registered: ‎08-08-2017

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

Hi, frankasmith568. Have you tried to follow the workarounds given by 

Gerard-21724
Wemo Technical Support
Highlighted
Posts: 1
Registered: ‎08-21-2018

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

I am having the same issues. Purchased a two pack of the plugs and neither of them are able to set up. 

Moderator
Posts: 188
Registered: ‎08-08-2017

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

@nplaskaHave you tried to reset and reconfigure the Wemo switch? What's the LED status? Is there any error message? 

Gerard-21724
Wemo Technical Support
Posts: 1
Registered: ‎10-03-2018

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

Same issue. I reboot the WeMo Mini but the app still shows wemo.jpg

Moderator
Posts: 355
Registered: ‎08-08-2017

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

@mingzhe

What's the current LED status on the WEMO Mini and how far is it from the router? If you had any changes with the router's setting, you'll need to reset and reconfigure the Wemo Mini. Once done, make sure you update its firmware.

Jo-Ann - 21744
WEMO Technical Support
Posts: 3
Registered: ‎07-31-2016

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"

It's really ridiculous to see so many users complaining of same problem and no permanent fix by wemo. Not hours, I have spent days searching internet, resetting devices, resetting router but no luck to get wemo app to register all swtiches. Every time I change my wifi password this stupid nightmare starts and it gets to frustration.. On three different hand helds I can't get pass the failure at discovering devices and I have to starting over and over again. I don't think that wemo would ever be able to fix this nonsense 

Moderator
Posts: 195
Registered: ‎08-22-2017

Re: WeMo Mini setup hangs at "Discovering your WeMo devices"


@Kamranata wrote:

It's really ridiculous to see so many users complaining of same problem and no permanent fix by wemo. Not hours, I have spent days searching internet, resetting devices, resetting router but no luck to get wemo app to register all swtiches. Every time I change my wifi password this stupid nightmare starts and it gets to frustration.. On three different hand helds I can't get pass the failure at discovering devices and I have to starting over and over again. I don't think that wemo would ever be able to fix this nonsense 


Hello there, Kamranata. Please know that we do understand your sentiments towards this matter. Take note that whenever you change some settings on the router (e.g password, or replace a router), you have to reset the Wemo device you have, and reconfigure it to the new Wifi password. However, you have mentioned that you already reset the Wemo devices. May we know what's their LED light status? For further isolation, you may try to power cycle the Wemo devices, force close the app and launch it again. BTW, please make sure that the Wemo devices are properly setup after resetting it. You may check this link for reference.

Nestor - 21974
WEMO Technical Support