WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 3
Registered: ‎12-17-2014

WeMo Set Up Problems - can't connect to WiFi

I'm sure this has been covered somewhere else, but any help is appreciated.  I'm having trouble setting up the WeMo outlet swtich.  

 

*Note that I did in fact get the device set up correctly once yesterday, but then the Firmware Update started and never stopped; after 3 hours of "updating", I gave up. My firmware is still way outdated (just bought the switch this week).

 

-I have been consistenly able to find and connect to the WeMo network.

-The WeMo app will not connect to my WiFi network (not hidden).   I have had multiple failures, followed by one success, followed by multiple (more than 15!) failures.

-Amber light on device constantly blinks now.

-Firmware will not update

 

What I've tried (all several times):

-Restarting iPhone 4S

-Unplugging router

-Resetting the WeMo switch

-Deleting and re-installing WeMo app

-Moving device closer to the router

 

Any ideas to try?

 

 

Posts: 1
Registered: ‎11-30-2014

Re: WeMo Set Up Problems - can't connect to WiFi

I have the exact same problem myself! But just on one Switch. Maybe the others will follow soon - no one knows! 
All the troubleshooting does not work, I cannot restart it. 
I will return it back to store and demand my money back! 
 
Very disappointed and will start looking for another brand to dump Belkin. 
I need a reliable product!

Posts: 29
Registered: ‎09-19-2014

Re: WeMo Set Up Problems - can't connect to WiFi

Hello KevinP. Try doing a hard reset again but this time, do not update the firmware. By the way, how far is the WEMO from the wireless router? Are there any range extenders or access points in your network setup? What is the make and model of your router?

Posts: 3
Registered: ‎12-17-2014

Re: WeMo Set Up Problems - can't connect to WiFi

Hello. Here's an update:

 

Router is a Centurylink ZyXEL PK5000Z

 

The SSID is set to Broadcast

No Upper Case letters are in the SSID (myquest####)

Security is set to WPA2 only

Selected AES

Switch is placed within 12” of the router

Not sure about range extender or access points in network.

 

Amber light on switch blinks almost continuously after about 5 seconds of a blue light upon doing hard reset.  Never got an option to do a Firmware Update.

 

When trying to use WeMo app to connect to network, get message "The WeMo App was unable to connect to..."

 

Any ideas?

Community Manager
Posts: 558
Registered: ‎05-27-2014

Re: WeMo Set Up Problems - can't connect to WiFi

Try a factory reset.  If it is only blinking amber that means it has settings and cannot connect to the network.  

 

- Unplug the unit

- Hold down the reset button

- Plug in the unit and continue to hold the reset button for 15 seconds

- Go grab a soda or do something that takes 60 seconds or so.

- Come back and see if it is blinking Amber/Blue or Amber/Green depending on the product.

 

Let me know if that helps.


Regards,

Robert S.

Belkin Technical Support

Posts: 3
Registered: ‎12-17-2014

Re: WeMo Set Up Problems - can't connect to WiFi

[ Edited ]

Tried the factory reset for the switch as described. Also tried shutting off and restarting router and iPhone (again, in all cases).

 

Light on WeMo swtich continues to blink Amber/Blue and error message continues to state that WeMo app cannot connect to network.

 

More ideas? 

Posts: 38
Registered: ‎12-18-2014

Re: WeMo Set Up Problems - can't connect to WiFi

[ Edited ]

A couple of thoughts:

 

1. Are you using any kind of access control on your router that restricts wifi access to certain MAC addresses?  If so, disable the access control until after your device is connected.

2. I've found that sometimes special characters and spaces in the SSID cause connection problems for some wifi devices, and special charaters in the password also cause problems.  My SSID is not broadcast and I don't have any connection problems with my WEMO devices.

 

You could try disabling the security options from your router, temporarily of course, just to be sure the device connects.  If it does, then at least you would know your SSID is ok.

Posts: 100
Registered: ‎05-28-2014

Re: WeMo Set Up Problems - can't connect to WiFi

[ Edited ]

WEMO devices supports WPA2 with 8-63 characters comprised of letters and numbers only. I also suggest that you try changing the SSID od your current WiFi network. It helps a lot for wireless devices that are not able to connect wireless.

Posts: 1
Registered: ‎01-25-2015

Re: WeMo Set Up Problems - can't connect to WiFi

We had a power outage yesterday. The Wemo disconnected and hasn't been able to access our router since.

 

I have done all the steps for hard reset.  It connects to the Wemo wifi but will not engage past the point of logging into our router.  I had no issues at first set up and have been using this product since January 1.  It was a Christmas gift and is new.

 

Please advise.  I've not made any other changes to our router settings, and the password is input correctly.

Posts: 964
Registered: ‎12-08-2014

Re: WeMo Set Up Problems - can't connect to WiFi

Probably not related to this at all but will throw it out there...

Only time I had something like that happen was when I configured too narrow of a DHCP pool on my router. I mostly do static reservations now to keep on top of usage.