WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Expert
Posts: 108
Registered: ‎06-17-2015

Re: WeMo Set Up Problems - can't connect to WiFi

[ Edited ]

@guut13

 

Hmm. That doesn't sound right. I'd suggest you do the following:

 

  • Try another handheld device (preferably an Android phone).
  • Unplug your WEMO for 20 seconds then plug it back in. 

If all else fails, reset it to factory default settings.

 

Ann_18678
WEMO Technical Support

Posts: 1
Registered: ‎09-23-2015

Re: WeMo Set Up Problems - can't connect to WiFi

I resolved my problem like yours. I hold the reset button for like 30 secondes. After this laps of time, I continu to hold the button and open my wifi setting. Select now the wemo light wifi. Go to the wemo app and now he see the light. After that, I released the reset button and it works again !
Posts: 1
Registered: ‎10-14-2015

Re: WeMo Set Up Problems - can't connect to WiFi

I tried your instructions on rest to factory. SUccessfully reset, flashed blue for a 30 sec, then went to flashing blue/amber. Selected network: wemo.switch.A6F on iphone (like all other wemo switched during setup), went to wemo app and get a error message again of :

 

check your internet connection and try again. Your mobile device cant reach wemo cloud........

 

All other wemo switches still work fine (4 - 2 wall and 2 light switches) but cant add this new one. Tried all recommended with router etc.

 

Any ideas......

Moderator
Posts: 340
Registered: ‎06-15-2015

Re: WeMo Set Up Problems - can't connect to WiFi

Looks like we have to try other steps. First, force close the WEMO app and reboot the iPhone. Before you proceed with setting up the new WEMO device, reboot the router and this time, power down the other WEMO devices. If you have another handheld device, using it would also help us isolate this challenge.

 

If you'll still get the same message, email us at WEMOcares@belkin.com together with your username, full name, phone number, location and the link to this post for further investigation.

Irish_16855
WEMO Technical Support
Posts: 1
Registered: ‎10-23-2015

Re: WeMo Set Up Problems - can't connect to WiFi

2 weeks ago I purchased 4 WEMO Osram Lightify kits and 8 extra bulbs and proceeded to attempt to setup the WEMO links following the written instructions but the when starting the iPhone app would always get stuck on the initial message displaying "Looking for Devices". After reading all these posts I tried all the suggested fixes.  I tried resetting the Wemo Link and repeating the process. I made sure to use WPA/WPA2 wireless security on my router with an 8 digit password that uses only numbers and my router is set to broadcast its SSID. I have tried to connect to the Wemo with and without MAC filtering enabled. I'm not using a dual band router - 2.4 GHz only. I tried changing wireless channels to 1, 6 and 11 and also tried channels, 2, 3, 4, 5, 7, 8, 9 and 10..I tried another iPhone and also attempted to try a spare Android phone but unfortunately the Wemo app is not compatible with my spare Android phone. I tried restarting my iPhone (and the borrowed iPhone). I tried uninstalling and installing the WEMO app on my iPhone. I tried rebooting my router. I made sure the power to the WEMO Smart LED Bulbs is switched to ON before searching for the devices. I tried updating my WEMO Link but there is no update shown in the WEMO app on my iPhone so according to a Belkin support article there is apparently no update for my WEMO Link available. The Wemo Link is plugged into an outlet about 10 feet from my Wi-Fi router. I made sure that there are plenty of addresses in my router DHCP pool. My router is directly connected to the internet. I emailed all this info to WemoCares and received several messages literally asking if I had performed each of the tasks which I already notified them that I tried. After being promised I would be contacted by a Level 2 technician I finally got a call today, only to be told that Belkin is aware of a problem with the iPhone app and that it doesn't work with the newest WemoLink devices. Belkin is apparently working on a fix for the app and cannot offer any assurances of when the new app will be available. Like several other posters here, I'm beyond frustrated about the several days I have spent trying to get these things to work and now find out that Belkin actaully knows that the new devices don't work - sheesh!  Back to the store they go. Fortunately there were two other manufacture devices with similar functionality sitting right next to these on the shelf at my local big box store, so bye bye Belkin.  Thanks for the education.

Posts: 1
Registered: ‎10-30-2015

Re: WeMo Set Up Problems - can't connect to WiFi

My eventual solution was turning off the 5ghz radio on my wifi. I have both 2.5ghz and 5ghz on the same SSID. I assumed like all my other devices that the WeMo would just use the 2.5, but it seemed to struggle... maybe this will help others.

Posts: 1
Registered: ‎11-01-2015

Re: WeMo Set Up Problems - can't connect to WiFi

Yet another user with the same issue.

 

Used it for a year or so and everything worked great.  Recently changed my SSID within my home network.  I went around and changed everything in the house and then got to the WEMO. 

 

I ended up doing the factory reset listed on the wemo site and this is where it all went downhill.  I have done all of the steps others have listed and tried.  I have gotten a bunch of different outcomes, but yet to get it working again. Ive gotten to a point where it looks like it was going to take and then it keeps barking that there is a firmware upgrade.  I have tried upgrading and not upgrading, neither solves the issue.  Not sure if the firmware upgrade hosed it or not, but ive burned countless hours on this thing and im about done with it. 

 

Ive used multiple ipads and iphones all running IOS 9 (wondering if its a ios 9 issue?)

 

WEMO support, please assist if possible.  Thanks

 

Expert
Posts: 259
Registered: ‎07-18-2015

Re: WeMo Set Up Problems - can't connect to WiFi

 

Hi prizmm. I suggest that you power cycle your wireless router. After that , perform another factory reset on your WEMO devices and configure it again. Once done, check if it will prompt for an update. In case you are still having some challenges, feel free to update us via email at WEMOCares@belkin.com with the link to this thread.

Posts: 974
Registered: ‎12-08-2014

Re: WeMo Set Up Problems - can't connect to WiFi


bcoyle wrote:

My eventual solution was turning off the 5ghz radio on my wifi. I have both 2.5ghz and 5ghz on the same SSID. I assumed like all my other devices that the WeMo would just use the 2.5, but it seemed to struggle... maybe this will help others.


I wouldn't run my 2.4Ghz and 5Ghz on the same SSID.

Posts: 13
Registered: ‎12-17-2014

Re: WeMo Set Up Problems - can't connect to WiFi

[ Edited ]

I have two devices (1 light switch, 1 motion) that dropped off the network sometime in the last few weeks, worked fine for over a year prior. I have 7 other WeMo devices (mostly light switches) working still. I spent an hour this past Sunday trying to reconnect the 2 missing devices with no luck. I can connect to the device directly via wifi but the WeMo app refuses to authenticate to my network from that point. No changes were made to my home network during this time and all the other devices connect without issue.

 

Things I have tried.

 

- rebooting main router

- shutdown second floor router

- reset wemo devices

 

I'll troublehsoot it some more this weekend when I am back in town. Ideas I plan to try yet:

 

- swap router mhz/channels

- disable WPA2 security

- move motion device within 5ft of router

- uninstall/reinstall WeMo app

- attempt setup on iPad vs iPhone (both ios 9.1)

 

When these WeMo devices work they are fine but over the last 2 years or so I've had them there have been several instances of problems requiring multiple hours of troubleshooting to resolve. Most of my initial issues were caused by firmware updates... Curious if this latest update is the root issue with these 2 devices, but I can't say for sure as I am uncertain exactly when they disappeared.