WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 2
Registered: ‎04-03-2017

Wemo App - Can't get past opening screens

I just donwloaded 17.1. I open the  app and I'm presented with two choices: Get Started and Lean More.

I choose Get Started and it prompts me with "which products are you setting up today?". I select Wemo Light Switch and it walks me through 5 screens. When I exit (X) out of the last screen, I'm retuened to the opening screen again (Get started).

How do I just open the App???

WEMO Maker Inventor
Posts: 1,676
Registered: ‎06-14-2014

Re: Wemo App - Can't get past opening screens

Connect your phone to the 2.4GHz SSID of your router then try again.  It should discover your devices and display them, skipping the getting started screen  Worst case delete app data or uninstall and re-install to try again - it's a bit buggy.

Posts: 2
Registered: ‎04-03-2017

Re: Wemo App - Can't get past opening screens

Nope.

Same result. Connected to my 2.4Hz SSID. Even deleted the app and downloaded again. Same result. Can't get past the "Getting Started" screen.

WEMO Maker Inventor
Posts: 1,676
Registered: ‎06-14-2014

Re: Wemo App - Can't get past opening screens

[ Edited ]

Wait, did you ever have the app and wemos working before?  'cause if not, what you've described is not the initial setup procedure. You should probably pick "learn more" and follow the instructions.

 

If the app & wemos have worked before than it's clearly a network issue that's affecting the new app install.  If you have any WAPs or network extenders they might be blocking the search.  Otherwise you'll need to wait for belkin to help here or contact them directly.

Expert
Posts: 171
Registered: ‎07-16-2015

Re: Wemo App - Can't get past opening screens


@bworrall

 

Same with MikeP's question, are you setting up a WEMO light switch or just downloaded the app on another phone? If you are setting up a WEMO, reset the WEMO light switch to factory defaults and then reopen the app to start the setup.

 

Chiqui-17359

WEMO Technical Support 

Posts: 1
Registered: ‎11-08-2018

Re: Wemo App - Can't get past opening screens

Hi I’ve got the same issue here. I did the factory reset on the WeMo Switch. And follow all the steps required by the app. After setting it up and I open the app, boom, it takes me back to the welcome screen and not showing any of my devices. I confirm the switch is working though as I can control it using some third party wemo control apps, but this official one just doesn’t work at all.
Highlighted
Moderator
Posts: 58
Registered: ‎12-12-2017

Re: Wemo App - Can't get past opening screens

Hello KevlarH2O. May we know the current version of your Wemo app? What's the LED status of the Wemo device in question as of the moment? As you mentioned, you can control the device using a third-party app. Have you tried using a different handheld device? If you haven't, please do so. Also, please make sure that the Handheld device you are using and the Wemo device are connected on the same 2.4 GHz network. Let us know how it goes.

Mark-22022
Wemo Technical Support