WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 5
Registered: ‎12-01-2018

Wemo Dimmer Apple Home Kit Error

I recently installed a new Wemo Dinner and I am able to 100% control the Dinner through the Wemo app for the IPhone 7 Plus. However, when I try to "port" the dimmer over to Apple HomeKit I am not able to connect to the dimmer switch. I have four Wemo mini switches and have had no issues connecting via Apple HomeKit. However, for some reason I cannot get the Dimmer to operate via HomeKit. Here are the steps that I am following:

 

1. I have named the dimmer Master Bedroom Light

2. I have successfully connected the dimmer via the Wemo app

3. I have updated the firmware so that the dimmer should work with Apple HomeKit

4. I then navigate within the Wemo app to Connect to Our Smart Home Partners

5. I then click Apple Home app

6. I then click Get Started

7. Under the screen Connect to Apple Home app - my Master Bedroom Light is listed as Not Connected - with a green button Connect.

8. I then click on Connect

9. Here is where the issue/error occurs: The Wemo app screen is called Add Accessory. Instead of Add "Master Bedroom Light" it says Add "Lightbulb". The "WeMo" app by Belkin is asking to add an accessory to your home.

10. I then click on the Blue button Continue.

11. The tile shows a Yellow lightbulb in the top left corner and the tile is labelled Lightbulb. Not Master Bedroom Light.

12. The screen says searching for accessory and eventually times out. My guess is that the app is looking for an accessory called Lightbulb - not Master Bedroom Light - and never finds it.

13. I get a screen with an exclamation point - Accessory Not Found - Try Again. Eventual time out.

14. I click Try Again and the same thing occurs.

 

Steps I have tried to correct:

 

1. Completely restarted the entire softwre and firmware install process - re-set all settings. Nothing.

2. I have named the Master Bedroom Light - Lightbulb to trick the software. Nothing.

3. Tried to use my IPad instead of my IPhone.

4. All software and hardware is up to date.

 

Hope that someone can assist.

 

Posts: 5
Registered: ‎12-01-2018

Re: Wemo Dimmer Apple Home Kit Error

Problem solved - I think.

 

I read on some of the message boards about users throwing breakers throughout the installation process. So I tried - I threw the breaker that controls my Master Beadroom, left off for about 10 seconds, and then turned back on. The WeMo dimmer reset. I then went back to the Add Accessory process and the device now shows up and works within Apple HomeKit. Not sure exactly why this fix works but so far so good. It should be researched by Belkin Tech Support and either resolved or added to the installation instructions. I called the free tech support, had to wait about 40 minutes on a Saturday, and the rep that I was dealing with did not know how to resolve and said that my case was being elevated to Level 2 Support. Will wait to see what this next level of support says.

Posts: 5
Registered: ‎12-01-2018

Re: Wemo Dimmer Apple Home Kit Error

Update #2

 

While the dimmer shows up in Apple HomeKit - it is constantly unresponsive. I was able to get it to work once for a period of no more than a few minutes. Once I closed HomeKit and restarted the app, the dimmer was Not Responding with an exclamation point. It still works from the WeMo app, but not HomeKit.

 

I would appreciate any suggestions.

Posts: 1
Registered: ‎12-03-2018

Re: Wemo Dimmer Apple Home Kit Error

Same problem here. My dimmer is also coming up as a "Light Bulb" and Homekit is not able to detect it.

 

I havn't tried toggling the breakers, but I performed a factory reset of the dimmer through the Wemo app and the Dimmer itself without any luck.

 

I've initiated a replacement and will see if the new dimmer will have the same issues.