WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 3
Registered: ‎03-04-2019

Re: Wemo app opens and closes constantly

I meant "any of my Wemo plugs"
Posts: 3
Registered: ‎03-04-2019

Re: Wemo app opens and closes constantly

so this has been going on for 6 months and still no fix. obviously not a priority for Belkin. so now I have to start posting on Amazon and Home Depot etc not to buy Wemo products.
Moderator
Posts: 301
Registered: ‎08-22-2017

Re: Wemo app opens and closes constantly

@pboutique

 

We highly recommend to send an email to WemoCares@belkin.com along with the contact details mentioned by @Fritz_R. The team will look into this further and run their diagnosis on the setback.

Carl_S 21985
WEMO Technical Support
Posts: 2
Registered: ‎03-06-2019

Re: Wemo app opens and closes constantly

I started experiencing the app closing within few seconds after opening as well. It shuts on both my iPhone and iPad. In addition all Wemo devices (smart plugs and switches) are showing “not detected”. I can see on my security cameras the lights are still turning on and off according to rules. However, I can’t access or change anything related to Wemo through the app. I tried a reset for app on the iPad, but lost all programming and information.

Moderator
Posts: 15
Registered: ‎02-14-2019

Re: Wemo app opens and closes constantly

@Clay


Hello there. Have you already tried deleting/ reinstalling the Wemo app? You may want to give this a try, and we’ll see how it’ll go afterward. BTW, when you said about doing a reset, is this with the Wemo devices through the app, or you just did a restart on the iPad? Please check, as well, for the current version of the firmware of the devices. Make sure that they're all running on the latest one.

 

 

Rowena_B 22017
WEMO Technical Support

Posts: 2
Registered: ‎03-06-2019

Re: Wemo app opens and closes constantly

Thanks for the quick reply. Firmware was updated about a week ago. For the iPad, I was able to enter app long enough before it closed to select “forget device” and then reconnect to try to reset app. When I did this, the app is back to a complete new setup. On the iPhone , I didn’t delete and reinstall app because I’m away from home for another 3 weeks and not able to access Wemo’s to add each on back to my app
Moderator
Posts: 15
Registered: ‎02-14-2019

Re: Wemo app opens and closes constantly

@Clay. Duly noted. We suggest to try on deleting/reinstalling, or using another handheld device, and run the Wemo app when you’re already with the devices. Please do keep us posted on how it’ll go after doing the suggested workarounds for us to properly isolate the setback.

 

 

 

 

Rowena_B 22017
WEMO Technical Support

Posts: 1
Registered: ‎03-24-2019

Re: Wemo app opens and closes constantly

Hello,

I was having the same problem as you on Galaxy S10+ with pie. Never had this before even though Wemos are always a pain to setup.


Not sure what it was specifically but here's everything I turned off.

Most important turn off "switch to mobile data" (wifi settings > advanced) Even though I had this off and had same problem. Next, turn off mobile data completely (Settings > connections > data usage > mobile data).

For good measure I also turned off: Blutooth, phone visibility, NFC communications. All those are under settings > connections. Also turn off Hotspot 2.0 (wifi > advanced > view more).

Finally under connections > more connection settings, turn off "nearby device scanning." After you've done this go to settings > apps and click on wemo. First click force stop. Next click on storage and click clear cache and clear data.

Now you should be able to start the process of setting up the Wemo. Once you click on the Wemo WiFi network the app should stay up instead of collapsing and opening. It will cycle and say working, still working, but then you should get the option to name the plug then it will finish up.
Posts: 3
Registered: ‎12-31-2018

Re: Wemo app opens and closes constantly

The same thing happened to me when I installed a new switch. I force closed the app, switched my wifi from the wemo back to my router and when I opened the app again it worked and I could complete the setup of my switch. Cant update the firmware on it yet but that's a completely different can of worms.