WEMO Application

Showing results for 
Search instead for 
Do you mean 
Posts: 85
Registered: ‎05-13-2014

Re: Wemo devices Not Detected

The device is a LGL34C with only 2.4Ghz wireless service. Not used as a cell phone. It does pick up my other 23 Wemo devices. Yesterday it did pick up my Wemo dimmer for a minute then lost it and now does not show up on the Wemo menu.

Posts: 179
Registered: ‎01-05-2016

Re: Wemo devices Not Detected

[ Edited ]

How far is the Wemo Dimmer from the router, cbknapp56? What's the status of its LED indicator? Try to reboot your Wemo Dimmer. To reboot, turn OFF the connected bulb, then press and hold the LED bar for 2 to 5 seconds.  Release the button when the LED bar is illuminated white. In that way, the connection between the F7C059 and the router will refresh. After that, check if the Dimmer will appear on the app of your LG device.

WEMO Technical Support
Posts: 85
Registered: ‎05-13-2014

Re: Wemo devices Not Detected

Christopher_S the Wemo Dimmer is 18 feet from the router, in the same 3 gang box with another working Wemo Switch and Leviton Z-wave dimmer device. The status of its LED indicator is white. I have now reset the Wemo dimmer using the  LGL34C device that did not register the dimmer before. I was able to setup the dimmer with this device but it still does not appear on the Wemo App on the LGL34C  device but shows up on Alexa and two other devices. 
Posts: 306
Registered: ‎06-29-2015

Re: Wemo devices Not Detected

All noted, cbknapp56. Let's endorse your case to our 2nd level Support Team so our Escalation Engineers can work with you and conduct a further diagnosis with this issue. Please e-mail us the following details and send it to us at WemoCares@belkin.com so we can open a ticket for you in our system:


  • Full Name:
  • Phone Number:
  • Location (state/country):
  • Android Version of Handheld Device:
  • Community Username:
  • Link to this Community Post (for our reference):

We look forward to hearing from you.

Dennis - 20702
WEMO Technical Support
Posts: 3
Registered: ‎10-07-2017

Re: Wemo devices Not Detected

I have three wemo mini switches and they are linked with the Amazon Alexa app via the wemo skill add-on. When I had only one unit everything worked really well. I just added two more with the help of tech support because the setup kept failing on both new units. I must first say tech support was very good. I used the on-line chat support. However, after reinstalling my wemo app and updating firmware on the new units I finally had them all installed and working. Then for some reason 2 of the 3 were no longer detected in the wemo app but everything worked fine in Alexa app. About an hour later both devices that were suddenly not detected earlier self corrected. Can this be due to a sync issue with the wemo systems?