WEMO Application

Showing results for 
Search instead for 
Do you mean 
Posts: 4
Registered: ‎01-24-2016

Wemo's Stopped working

I've been using Belkin Wemos for over 3 years now. In the early days they were real buggy but after the app rewrite they have been rock solid for the last year or more. About 3 weeks ago all of a sudden all my Wemo devices (about 12 total) dropped offline and now simply refuse to connect. When I go into the wemo app, most of the devices dont even show, the 4 or 5 that do are completely unresponsive. Looking at the devices they are all flashing letting me know they arent connected to Wi-Fi.


I have tried doing a manual reset and reconnecting several of them but they refuse to connect. I'm using an Asus tri-Band router, with an Asus dual band router upstairs connected as a repeater. I broadcast 2x 5ghz networks (I know the Wemos cant use 5ghz), and 2x 2.4ghz (one home, one guest). I'm using WPA2 AES security. I've tried connecting my Wemos to both the home and guest 2.4ghz networks and all I get is the cant connect message. For the time being I've disconnected my repeater to make sure it wasnt causing any issues. Still no luck connecting.


 The oddest part is that everything was working great up until 3 weeks ago. I made no changes to my network names or passwords. I've havent made any network changes in the last year or so. I simply noticed one day the WiFi was acting up with everything in the house so I rebooted the router. Everything else working on WiFi (Ps4, Xbox One, Mutltiple Computers, Security Cameras, Firesticks etc..) all picked right back up and are working fine. A few of the wemos hopped on for awhile but now they have all dropped off and refuse to connect.


Steps i've done so far

-I've rebooted router and upgraded firmware

-I've uninstalled and reinstalled the Wemo app

-I've disconnected my repeater to make sure it wasnt an issue

-Made sure passwords are simple character and number only, no spaces

-Factory reset Wemo and tried to reconnect (Get cant connect message and takes me back to select Wi-Fi screen.)

Posts: 1
Registered: ‎03-02-2018

Re: Wemo's Stopped working

I am having the same issues. I recently moved to a new home and had to wait to put in my switches. That was 7 months ago. I cannot connect them to anything and have tried diffrent youtube tutorials to try an connect but no joy. I really like the switches and hope this is not a sign of things to come.

Posts: 295
Registered: ‎08-08-2017

Re: Wemo's Stopped working

@AdioKIP, let's have our 2nd Level Support Team check on this. Please email us your contact details at WemoCares@belkin.com along with your community username, and the link to this post for reference. Also, please include letting us know the model number of the WEMO devices that you're having issues with.




Allow us to look into this. Can you share with us the workarounds you've done so far? Have you made any changes to your router since you've moved to your new home? If so, were you able to reset your switches to its factory defaults? How far are they from the router?

Jo-Ann - 21744
WEMO Technical Support
Posts: 4
Registered: ‎01-24-2016

Re: Wemo's Stopped working

Thanks for the offer of assistance but I finally managed to get them working again. The only solution that worked for me was to rollback my routers firmware. Not sure what it is about the latest firmware update that the wemos dont like but after trying it several times I could never get them working properly. As soon as I rolled back the firmware of my router to the previous version all my wemos came back online within 5 minutes. 


It would be interesting to know if anyone with the same router encounters the same issue. I'm running an Asus Tri Band AC 3200 with an Asus dual Band AC66U being used as a repeater.


With firmware posted 01/25/2018 my wemos refused to work properly. When I rolled back to firmware everything started working perfectly like it has been for the last year or more. With both firmware I used the EXACT same settings. With the updated firmware I tried turning off QOS, changing channels, changing bands, renaming my ssid to something simpler and a whole lot of other things but could never get the wemos working properly.