WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 8
Registered: ‎03-11-2018

Wemo smart plugs one hour off?

Hi, I have a number of wemo plugs that I have been having trouble with in terms of getting the scheduled off-on to work. Here's what's been happening: If I set up a rule to turn them on at, say., 8 AM, they turn on promptly at 9 and turn themselves off at one hour after I set them to. If I set up a rule to just turn them on then that works at the correct time.  Wifi connection is good, the app works fine to connect to the wemos, I can turn them onn/off manually,  the location is set correctly in the app, and the time is correct in the phone (iphone x.)  I had thought that the scheduled on-off wasn't working at all, but now that I see it's just an hour late I can work around it; however, it's rather strange that a rule that just turns a plug on works at the correct inputted time but scheduled on-off does not.  I have not tried reinstalling the app, am a little reluctant to risk messing something up by doing that, but please advise. Thanks!

Moderator
Posts: 103
Registered: ‎08-22-2017

Re: Wemo smart plugs one hour off?


@Exasperatedwrote:

Hi, I have a number of wemo plugs that I have been having trouble with in terms of getting the scheduled off-on to work. Here's what's been happening: If I set up a rule to turn them on at, say., 8 AM, they turn on promptly at 9 and turn themselves off at one hour after I set them to. If I set up a rule to just turn them on then that works at the correct time.  Wifi connection is good, the app works fine to connect to the wemos, I can turn them onn/off manually,  the location is set correctly in the app, and the time is correct in the phone (iphone x.)  I had thought that the scheduled on-off wasn't working at all, but now that I see it's just an hour late I can work around it; however, it's rather strange that a rule that just turns a plug on works at the correct inputted time but scheduled on-off does not.  I have not tried reinstalling the app, am a little reluctant to risk messing something up by doing that, but please advise. Thanks!


This seems a bit odd, Exasperated. The rule should be accurate if it was properly setup. In your case, you can try to recreate the rule and see how it goes. Check this link for reference. You may try to use another handheld device as well and observe. 

Nestor - 21974
WEMO Technical Support
Posts: 8
Registered: ‎03-11-2018

Re: Wemo smart plugs one hour off?

Thanks for the quick reply - I have tried re-creating the rules many times with the same result. I will check the link though - also, what I haven't yet done is tried another handheld device to run the app; I don't have another one here at the moment that I might use. Is there any reason to think re-installing the app might help? Will it screw anything up?

Posts: 8
Registered: ‎03-11-2018

Re: Wemo smart plugs one hour off?

Another new discovery: if I set up two separate rules, one to turn on at time X and another to turn off, then it works correctly. So this is not too hard to do as a workaround obviously, but something is clearly funky/not right with the schedule on/off rules.

Moderator
Posts: 216
Registered: ‎08-08-2017

Re: Wemo smart plugs one hour off?

@Exasperated

 

There might be a bug/lag on the App that's why we have to uninstall/re-install it and so we could check to isolate where the issue might be coming from. Have you also checked if your WEMO plugs are running the latest firmware and your phone is at its OS version. If you are still having issues, let us know so we can endorse your case to our Support Team for further diagnosis.

Jo-Ann - 21744
WEMO Technical Support
Posts: 8
Registered: ‎03-11-2018

Re: Wemo smart plugs one hour off?

Jo-ann,

 

Thanks. yes the wemos are all at the latest firmware and IOS is updated as well. I just re-confirmed the 1-hour lag if I set up a scheduled on/off rule.  I also just realized that I may have an old phone in the house, so will try to find that and install the app in it and see if it behaves the same way. Will let you know.

Posts: 8
Registered: ‎03-11-2018

Re: Wemo smart plugs one hour off?

I re-installed the app. One original wemo plug now works correctly, however the mini is still one hour off, as reported above.

 

Honestly, this is not worth my time to keep trying things; for now I will set up a rule to come on one hour earlier than I actually want it to, and a separate rule to turn it off, since the scheduled on/off rules are not working at all on this plug. I appreciate the quick replies here, but do want Belkin to know that before continuing to add new features, this customer would appreciate merely having the existing ones work correctly!

Posts: 8
Registered: ‎03-11-2018

Re: Wemo smart plugs one hour off?

One last observation: If I set a rule to turn the plug ON at, say, 9:30 AM, it comes on at exactly 10:30. I just noticed as well that if I set an auto-off rule to turn it off after 4 hours, it counts the 4 hours from 9:30 - IOW, it will turn on at 10:30 but turn off at 1:30.

 

I have re-installed the app and also reset the plug multiple times.

Moderator
Posts: 134
Registered: ‎08-08-2017

Re: Wemo smart plugs one hour off?


@Exasperated wrote:

One last observation: If I set a rule to turn the plug ON at, say, 9:30 AM, it comes on at exactly 10:30. I just noticed as well that if I set an auto-off rule to turn it off after 4 hours, it counts the 4 hours from 9:30 - IOW, it will turn on at 10:30 but turn off at 1:30.

 

I have re-installed the app and also reset the plug multiple times.


Alright. We'll have this taken care of by our Support Team, please email us at WemoCares@belkin.com along with your Phone Number, Location, Username, and Link to this Community thread for reference.

Gerard-21724
Wemo Technical Support
Posts: 8
Registered: ‎03-11-2018

Re: Wemo smart plugs one hour off?

Gerard,

 

Thank you for your help! I will do so, though time pressure forces me to find another solution for now. Will re-visit this in a few weeks, and hope that in the interim a firmware update fixes the problem.