WEMO Application

Showing results for 
Search instead for 
Do you mean 
Posts: 4
Registered: ‎11-05-2017

Re: Wemo switch becomes unresponsive "Not detected"

Yes, once the switches become unresponsive even manual operation is not possible.  WEMO technical support is saying that this is a very rare case that this happens...I said its not that rare....there are 17 pages on your comunity board talking about it.  She did suggest it might be something on their end when they are about to release a firmware update and the switches lose connection to the server.  


I have not tried DHCP reservation and that actually is a very good idea.  I will try that tonight and then play the waiting game lol.  I really appreciate the help. 


I completely agree that it is a safety hazard now that you mention it. it might be worth investigating that angle. Might get some real answers and fixes.



WEMO Maker Inventor
Posts: 1,796
Registered: ‎06-14-2014

Re: Wemo switch becomes unresponsive "Not detected"

Sounds to me like the devices have crashed - going from the physical switch to the relay should be internal. I hope they're not going through their cloud for that!  Actually I know they're not 'cause I can block the switches from reaching the internet and they still work.  So if the switch isn't working the device is probably not running at all.


If so there may be something in your network belkin didn't bother to test - possibly SSID or password characters, or some setting in the 2.4GHz signal width, or a performance setting, or yeah, DHCP, something like that.  You might see if you can configure your router with bog simple/slow settings to see if that helps.  Or if you have an old router or a guest network maybe move them to that as a gateway through your current router.  It seems to be a design flaw rather than a broken device that could be returned/exchanged, I doubt it's something the service team can help with...

Reliable and secure (Belkin cloud-free) home automation and remote access:
Posts: 3
Registered: ‎11-14-2018

Re: Wemo switch becomes unresponsive "Not detected"

I have had wemo devices for a couple years and have been having this same problem of them becoming unresponsive this last few months. Is there a fix to this? Mine too cannot be operated manually or with the app, I have to unplug the plug in devices and replug them in and wait about 1 min to operate the device. very frustrating.

Posts: 2
Registered: ‎12-07-2018

Re: Wemo switch becomes unresponsive "Not detected"

Of note, I am also having the same issue. Any options for resolution. Will there be an additional firmware update soon?
Posts: 3
Registered: ‎10-31-2017

Re: Wemo switch becomes unresponsive "Not detected"

I never did solve it.  Even put in all new Ubiquiti Unifi WiFi APs, Switches, the works.  Everything else works great!  Never have to reset anything except Somfy blind controller once in a blue moon, but WEMO, totally unreliable!  I have about 25 units in a box collecting dust.  Everything replaced with Smartthings, TP-Link, Etc.  So happy to be done with Wemo.  Firmware, LOL, not gonna fix garbage chipsets and circuitry!  They have not been able to fix in 4 years, they will never fix.  Seriously, I don't even want to GIVE them to my relatives!  Too embarassing.


Posts: 1
Registered: ‎03-05-2019

Re: Wemo switch becomes unresponsive "Not detected"

[ Edited ]

I have been using Wemos for about 3 years and quite frankly they are horrible products with horrible customer support. I have tried the Insight plugs and just recently the Minis. All of them have gone into not detected state. Just horrible I have posted numerous support tickets and there has never has been a resolution.


Wemos are inadequate for remote control of anything. Today, I went into my app and sure enough the Wemo Mini says "Not Detected". I'm going to try to return to Costco. In the meantime, I'm going to try out a different product from a competitor.