WEMO Application

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 1
Registered: ‎10-29-2014

Wemo switch becomes unresponsive "Not detected"

Twice now my wemo switch stops being responsive and says "Not detected" on the WeMo app on iOS 7.1.2. It is very disapointing and annoying. I am using the latest firmware and app version.

 

The only fix is to unplug the WeMo switch and replug and it works normally again.

 

It may sound like a joke, but it would seem that I need another WeMo Switch to fix my first one when it becomes unresponsive...

Posts: 29
Registered: ‎09-19-2014

Re: Wemo switch becomes unresponsive "Not detected"

The switch may be intermittently connecting with your wireless router. Try changing the wireless channel (router) to either 1, 6, or 11. This should minimized frequent disconnections. By the way, how far is the WeMo switch from your router?

Posts: 9
Registered: ‎11-23-2014

Re: Wemo switch becomes unresponsive "Not detected"

I'm researching whatever is causing me to have problems with my WEMO switch and the only thing I've been able to figure out is that it seems to be an issue regarding which 2.4ghz channel my router is set to.  I don't understand why that matters for WEMO since it doesn't seem to matter for any other wireless devices I own.  My iPhone always works.  My iPad always works.  My Apple TV always works.  My Philips Hue always works.  My Mac never has any problem connection to my router...  but WEMO is finicky.  WHY?

 

It seems that channel 1 usually works.  Channel 6 sometimes works (WHY?) and Channel 11 usually doesn't work.  ???

 

I keep seeing people in this forum say to check which channel the router is set to, but I want to know why.  Why does WEMO  have trouble with this when other wireless devices don't?  It's very frustrating.

WEMO Maker Inventor
Posts: 1,390
Registered: ‎06-14-2014

Re: Wemo switch becomes unresponsive "Not detected"

It doesn't in my experience.  The only important thing for the Wemo's is that you set your channel to be fixed rather than automatic - last time I tried it the wemo's struggled to find the new channel if your router changes.  Setting your channel like this appears to be a bug in the support team's script, not in the wemo itself.

Posts: 100
Registered: ‎05-25-2014

Re: Wemo switch becomes unresponsive "Not detected"

 

Hi 2oh1! It's possible that there's something wrong with the app. But, we can try isolating this. Aside from adjusting the wireless channel, why don't you try installing the app on another handhdle device and see if it wil show the same thing. You may also perform a factory reset and configure the switches again. 

Posts: 9
Registered: ‎11-23-2014

Re: Wemo switch becomes unresponsive "Not detected"

I'm not having trouble with the app.  I'm having trouble with WEMO on my wireless network.  The iPhone app usually works, but I have no interest in reaching for my phone in order to trigger WEMO.  That's a great feature to have, but as the only way to control WEMO, it defeats the goal of home automation since reaching for an iPhone app can't be automated.

 

I want to control WEMO on my Mac.  I've been able to do so for a year and a half, but it's always been clunky (effective but clunky) because WEMO is so finicky on a network and because the WEMO firmware is junk.  Instead of an iOS SDK, why not create an open API similar to Philips Hue in order to let people create apps for other platforms?

Posts: 100
Registered: ‎05-28-2014

Re: Wemo switch becomes unresponsive "Not detected"

[ Edited ]

Try changing the WEMO's location in your network. Make sure that its location is getting at least three bars of signal from the router to avoid intermittent connection. Also, once you've set rules on the WEMO devices, you no longer need to use your phone to trigger the WEMO. You can create a variety of rules and IFTTT recipes to automate your home with WEMO.

Posts: 84
Registered: ‎08-18-2014

Re: Wemo switch becomes unresponsive "Not detected"

[ Edited ]

This is a common problem and ongoing issue in my experience.  

 

My 16 Wemos do the exact same thing...go on and off become unresponsive, and crash.  My outside lights go on and off and become a safety issue.

 

I too have tried all channels, and settings. reset and reconfigured all wemos to no avail.  It's not a signal or interference issue as I've scanned all the channels using inSSIDer and other apps to verify signals in my neighbourhood.  Even switches that are close to the router are having issues. It appears to be a communication problem between the router(s) (Belkin Linksys WRT1900AC and Netgear EX6200) and the wemos, and it is becoming frustrating....

 

No response from Belkin.

Posts: 137
Registered: ‎06-03-2014

Re: Wemo switch becomes unresponsive "Not detected"

They did release a newer firmware. Make sure that they're all up-to-date. 

Posts: 84
Registered: ‎08-18-2014

Re: Wemo switch becomes unresponsive "Not detected"

Running .7166 on the plugs and .7398 on the switches.

 

Is there newer? Can't tell right now because everything is greyed out....switches won't tell me if there's an update.