WEMO Application

Showing results for 
Search instead for 
Do you mean 
Posts: 3
Registered: ‎09-18-2017

Re: Your product really sucks


I am mystified at how the engineering on this product has evolved.  When I first deployed one as a test on my old slow wireless network it came right up and worked fine with good reliability.  Over the past couple of years I have migrated to about 30 working devices, controlled mostly via one of our 9 Amazon Echo devices.  Love the Echo by the way.  Recently you rolled out a firmware update - about a month ago- and my devices started dropping like flies.  It was like a random event to have one actually function.  Some functioned using only the Echo, some functioned only using the app.  Some would function with either but most would only function manually.  And it changed almost on an hourly basis.


So made the jump to an eeros wireless network.  I have three of the version 2 eeros in the house.  They work well with all my devices including exterior security cameras capturing video. 


I spent litterally DAYS crawling around the house reconnecting all my Wemo devices while my wife asked me "when is my crap going to work again?"


I found that some - maybe 30 percent - devices successfully went through the manual reset, link to iphone, open wemo app, get the wemo app to recognize the wemo device, reset the network pointer in the wemo device, and then close the device, switch networks, and for what ever reason lets go hunt for all wemo devices once more on the iphone.  But the other 70 percent it DOES not go as designed.


It can take three or four reset, link, link, search, point, link search cycles to get through and successfully relink the individual switch.  Many (most) times the app goes off to find wemo devices and NEVER COMES BACK.  If you manually terminate the step, then you have to start all over again with the reset, link, link search point  . . . bla bla ad nauseum.  If you wait on the app to complete it MAY NEVER COMPLETE and you are left dumbly starting at the phone in a closet on your hands and knees for far too long.


I got so disgusted I deinstalled the app and reinstalled it.  What ever you do DONT go through this step.  It took almost an hour for the wemo app to actually come back and function again and then I had to MANUALLY add ALL my devices again.


here is what we need to make this product line a viable proposition and a serious consideration for home automatin

1) we need a management tool that will run on a Windows box that will allow us to configure and manage all devces in a structure.

2) common security practices call for regularly changing the wireless passwords but now that task is so onerous that either we accept the risk or we junk all the wemo devices and move on to some other solution

3) offer a "professional" level of product that is more robust and can meet the needs of 1 and 2 above.


Until then, you are living on borrowed time because as soon as someone comes along with the above functionality your product will become a toy for hobbiests where it currently fits quite nicely

Posts: 8
Registered: ‎09-17-2017

Re: Your product really sucks

Posts: 1
Registered: ‎07-29-2018

Re: Your product really sucks

Agree. Never holds their settings. Can't connect. Waste of money..

Posts: 65
Registered: ‎12-12-2017

Re: Your product really sucks

[ Edited ]

Hi, hav3atps. Please allow us to assist you. Are you having some connectivity issues with your Wemo device? Please share with us the details of your concern.

Elyza – 22075
WEMO Technical Support
Posts: 1
Registered: ‎09-26-2018

Re: Your product really sucks

Once again, just wasted a bunch of time trying to get this garbage product to work. And it's not like I don't understand what i'm doing, I'm a network engineer, I work with wireless everyday, but this product is just pure unaltered crap. 


About a year ago, I regretfully decided to use Wemo switches for all my single pole switches. Since then, everytime I even think about touching my network, all the wemo switch go down and then I end up spending hours trying to get them back online.


I just added another AP, lost connection to all switches. Same SSID, same password, all I did was connect a new AP.


I'm done with this. I use Lutron for multipole switches and Hue for color lights, and I have never had an issue with either product. Even TP-link's horrible KASA is lights years ahead of Wemo when it comes to reliability.


Now I'm going to swap out all my Wemo switches (around 10), which will still take me less time than trying to set them up for the millionth time.


Complete garbage.



Posts: 125
Registered: ‎08-22-2017

Re: Your product really sucks

Allow us to have Escalation Engineers assist you further, electonfun. Please email us at WemoCares@belkin.com along with the following details:


Full name:
Phone Number:
Email Address:
Community Username:
Link to this post:
Wemo App version:
Wemo devices' model number:


We hope to hear from you soon.

Rosalyn - 21986
Wemo Technical Support
Posts: 5
Registered: ‎09-22-2018

Re: Your product really sucks

I have worked with an escalation engineering only to be told they cannot reproduce my issue. Offered to send me a replacement device which was already done once before and did it solve issue. I gave up on Wemo.

For those wondering, my issue is when WiFi radio on my router is restarted or even a reboot of router courts I have to manually reboot each wemo for it to reconnect to WiFi. Luckily I only have 1 wemo device but was looking to purchase 10 more. I did not want to have to run aaay my house manually reboot Every time my router reboots. I have over 15 other smart devices(video cams, door locks, TV controllers, etc) which all are able to reconnect without ANY issue.

I ended up going with another manufacturer. Purchased 10 light switches and all 10 are able to reconnect to my WiFi without issue.
Posts: 1
Registered: ‎12-18-2018

Re: Your product really sucks

I agree 1000%. Wemo is the worst product on the market. Absolute Garbage.


Setup couldn’t be more frustrating. Reliability is horrid. Don’t even think about changing your router or AP with this product or you are doomed. Complete nightmare.


I have the entire house automated with Smartthings, Philips, Lutron, Echo/Alexa, Harmony, Apple, Nest, GE, Wemo, etc. Lighting, Cams, Alarm System, Schedules, Notifications. Everything works flawlessly.....except Wemo.


I manage an IT Department and I have never been so frustrated with a product.....Ever.


All the Wemo is coming out of my house and I’m replacing it with Lutron.


Posts: 1
Registered: ‎01-13-2019

Re: Your product really sucks

Same as the rest. Bought the WeMo light switch and plug combo. Junk, just junk. 10 feet from my router and keeps asking me for password after it sits there not connecting. Reset, restart, re-install. Doesn't work. Should have know. Belkin is cheap Garbage products.
Posts: 167
Registered: ‎12-12-2017

Re: Your product really sucks



Is the issue the same on both Wemo light switch and plug? Have you tried to use a different mobile device to connect the Wemo device to the router? If you haven't, please give it a try for isolation, and try to force close the Wemo app to see if that will make any difference. If that doesn't work, please try to disconnect your mobile device from your Wi-Fi and reconnect to the 2.4 GHz network then see if it makes any changes.


Jan - 22019
WEMO Technical Support