WEMO Application

Showing results for 
Search instead for 
Do you mean 
Posts: 1
Registered: ‎01-06-2019

wemo switches and mini failing to connect and fully restore in new apartment with new WiFi

have looked at similiar posts and tried some of the ideas, and still am needing help.


I have two switches i have been using for a year, and one mini i just bought (hoping it would work where the switches have been having issues. The bulkiness of the switches forces me to use an extra extension adapter, so i figured it'd be nice to update them with the mini anyways).


the issue and what i've tried

since i got new internet, with AT&T Fiber, i have not been able to connect the switches. I have held the restore button whilst plugging them in, and they both have the two colors LED blinking. I add new device in the app (Android Oreo) for each, and successfully go through the steps - it finds the WeMo WiFi for each switch each time, allows me to set the name and icon, and ends with the "Now you can remote control" screen (not exact verbiage). From there, i end up where i started - the home screen showing faded list if what the switches used to be, offering to hide them since they are unavailable.


After this, each device continues to blink the two colors LED, and never is seen by the app. I have tried:

  • force closing app
  • uninstalling / reinstalling app
  • trying to add device again, which yields same results.
  • logging into my router to turn off the 5ghz radio, which made no difference. ( i am not crazy about since i am paying a lot for AT&T fiber.)
  • bought the mini, got exact same results.
  • firmware is updated
  • there might be something else i tried but can't remember

So today, i have these three all plugged in with their two color LEDs perpetually blinking. Does anyone have any advice? Obviously, i need (want) these things working!