WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Posts: 2
Registered: ‎12-09-2018

Alexa and wemo app not responding

I've been working on this for months and have tried to research this problem but there's so much out there. Please forgive me if I've missed the solution.


I have an Amazon Echo, Wemo smart plug and a Wemo light switch. About 6 months ago I had to get a new router, Netgear Nighthawk 2600. Prior to that, everything worked perfect. Now I've had all kinds of problems. When I first set up my devices with the router they worked fine but soon after annoying things started to happen. These are just a few of the problems:


Wemo app not recognizing one or both of the devices. It'll recognize one today but not the next without any firmware or software updates, etc.

Alexa will not recognize one or both of the devices. And yes I do have the skill enabled.

Alexa will not recognize a device but will be able to turn it on or off within a group.

Alexa gives me a error: "sorry, provider is having trouble."


I've been living these problems for months and would work on them when I had time or they became real annoying. I've watched the tutorials and help videos. I've even spoken with a tech who got things working then the next day they gave me the same problems.


This is my current problem:

My Wemo app recognized the Wemo plug but not the switch. The Alexa app recognized and operated both but Alexa voice could only operate the switch and gave the before stated error message with the plug. It would operate the device when used in a group of Hue Hub products. 


So, I reset my Wemo switch to factory defaults and got it working just to have the plug become responsive. Seriously? I then reset the plug and got that working again with the Wemo and Alexa app. Right now I'm still getting the error from Alexa but it's still working within the group and individually with both apps.


Any ideas?

Thanks for reading my rant.

Posts: 221
Registered: ‎08-22-2017

Re: Alexa and wemo app not responding

We do understand your sentiments towards this matter, jfrench55. Just to verify, when you replaced the router, have you reset the Wemo devices and reconfigure it again to the new router's network? Please make sure that the remote access feature is enabled so you can control the devices on Alexa app.


BTW, do you also have a different 3rd party apps that we can possibly try, and check if we can control the Wemo devices there?  If so, let's integrate the Wemo devices on that particular 3rd party app and let's observe.


With regard to the challenges you're having with your Wemo devices right now, you may try to disable the Alexa skill and re-enable it again. As well as the remote access feature. 

Nestor - 21974
WEMO Technical Support