WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
wrd
Posts: 7
Registered: ‎04-09-2019

Can’t keep dimmers working with HomeKit

I added a third Wemo dimmer switch today, and have had nothing but grief since. Most of the time, attempting to connect with HomeKit results in an “Accessory Not Found” error. If I do get one connected, one of the others stops responding within minutes. I’ve tried a factory reset, circuit breaker power cycle, and re-setup on all three, at which point they worked for about fifteen minutes and then one of them dropped out.

 

Before adding the third, the first two had been working without fuss for a couple of weeks.

 

Relevant info:

 

A Netgear Nighthawk router (latest firmware).

iPhone Xs (12.2).

Three Wemo dimmers (all with 2.0.0.11215).

wemo app 1.22.1

Home app (latest).

 

All three dimmers work just fine with the Wemo app, so they’re talking to the router OK. I have no better luck adding the dimmers to HomeKit using the connect feature in the Wemo app, or by manually entering the HomeKit ID number.

wrd
Posts: 7
Registered: ‎04-09-2019

Re: Can’t keep dimmers working with HomeKit

Oh, another oddity: I wanted to try removing them from HomeKit and re-adding them. As per the instructions, I went into the Home app and selected Remove Accessory for each of them. The dimmers disappeared from the Home app, as expected...but the Wemo app indicated that they were still connected to HomeKit, making it impossible to re-add them without first performing a factory reset.

Moderator
Posts: 403
Registered: ‎08-08-2017

Re: Can’t keep dimmers working with HomeKit

@wrd

Have you also tried observing this on a different compatible phone if the same "Accessory Not Found" still appears? Try to uninstall/re-install the HomeKit App for isolation. If this does not change anything, please send us an email at WemoCares@belkin.com along with the following details so we can have our 2nd Level Support Team assist you further:

 

-Complete Name
-Phone Number
-Email Address
-Location
-Mac Address of one (1) WEMO Dimmer
-Community Username
-Link to this post for reference

Jo-Ann - 21744
WEMO Technical Support
wrd
Posts: 7
Registered: ‎04-09-2019

Re: Can’t keep dimmers working with HomeKit

I have tried it on an iPad (running the same version of both apps).

 

I have tried uninstalling both apps, both with and without deleting my home data and starting from scratch.

 

I sent an email a few hours ago with all the information except the MAC address. I’ll follow up with that information.

Moderator
Posts: 403
Registered: ‎08-08-2017

Re: Can’t keep dimmers working with HomeKit

@wrd

Thanks for the update. Do include the link to this post so the Team can associate this post from the contact you sent via email.

Jo-Ann - 21744
WEMO Technical Support
wrd
Posts: 7
Registered: ‎04-09-2019

Re: Can’t keep dimmers working with HomeKit

OK, after scouring r/HomeKit and a ton of mucking about, I have all three dimmers connected to HomeKit and, for now, responding. The process that eventually worked was, frankly, ridiculous. I factory reset all three switches, deleted the Wemo app, turned off cellular data, told my iPhone to forget the 5GHz network, and then for each switch I followed the following procedure:

 

  1. Delete the Wemo app.
  2. Reinstall the Wemo app.
  3. Switch to the dimmer’s network.
  4. Open the Wemo app and wait for it to connect to the dimmer.
  5. GIVE THE DIMMER A NAME THAT HAS NEVER BEEN USED BEFORE. Doesn’t matter what it is, you’ll change it later.
  6. DO NOT REMEMBER WIFI SETTINGS. The dimmers *never* worked when set up with this enabled.
  7. DO NOT SELECT THE NETWORK EVEN IF IT SHOWS UP IN YOUR LIST. Type the network name in manually. The dimmers never worked without doing this, either.
  8. Once the dimmer is set up in the Wemo app, turn the light on and off a couple of times to make sure it’s responding.
  9. Make certain remote access is enabled.
  10. DELETE THE WEMO APP AGAIN.
  11. Reinstall the Wemo app again.
  12. Navigate to the Wemo app’s “connect to HomeKit” screen.
  13. Hit the connect button.
  14. When the HomeKit screen comes up, you can rename the dimmer and set the room.
  15. Repeat for each dimmer. 

CONCLUSION: The app’s got issues. If the dimmers weren’t so pretty and $30 less than my second choice, I’d have replaced them by now.

 

It remains to be seen whether the dimmers will keep functioning or drop back into “Not responding” mode. I’ll update with the result.

wrd
Posts: 7
Registered: ‎04-09-2019

Re: Can’t keep dimmers working with HomeKit

And the bedroom dimmer has once again stopped responding.

WEMO Maker Inventor
Posts: 1,796
Registered: ‎06-14-2014

Re: Can’t keep dimmers working with HomeKit

If it helps, my aftermarket app AutomationManager lets you setup a server on android that eliminates the connection problems.  There's an add-on HomeBridge for AM that let's you get to your devices from HomeKit and doesn't have these issues, and gives you a lot more options for automation.

Mike
Reliable and secure (Belkin cloud-free) home automation and remote access:
AutomationManager/HomeBridge/WemoLEDs/WemoHome/MoreInfo
Posts: 9
Registered: ‎03-30-2019

Re: Can’t keep dimmers working with HomeKit

There's something currently very wrong with the WeMo dimmers. None of mine in my house are working with my Alexa, and sometimes they don't even show up on the WeMo app now. They used to work fine, but as of about 2 weeks ago when there was a firmware update, everything went to hell. My WeMo minis are totally intermittent, and the one regular light switch I have seems to work okay with my Alexa, but doesn't show up on the WeMo app. And it only works with voice activation, none of the switches show as connected on the Alexa app. I've got about $500 plus invested in WeMo light switches, and as of about two weeks ago they have all become crap. I just spent 3 hours the other morning on the phone with someone from Belkin, having me reset, restart, uninstall, reinstall, unplug my Alexa's, restart my phone, and nothing seemed to help. There's something very wrong going on since the last firmware update, and I hope to God they fix it.
wrd
Posts: 7
Registered: ‎04-09-2019

Re: Can’t keep dimmers working with HomeKit

Friday night, they all started responding in HomeKit, and have been working ever since. I had made no changes since my previous post. So I really have no idea what’s going on.

 

As it happens, Friday morning I ordered another brand to compare and see if I had better luck with it. It arrived yesterday, so I removed the Wemo from the family room and installed the new dimmer. Lo and behold, setup was quick and flawless, and as a bonus, my LEDs stopped buzzing. I’m now tempted to switch brands (I still have time to return the Wemos to Amazon), because having no idea why they started working, I have no great certainty that they will continue to work, and having buzz-free lighting is really quite nice. The only thing holding me back is that I really do prefer the aesthetic of the Wemo, and it’s significantly cheaper (but that may have something to do with the buzzing!)

 

I’ve got until Thursday to make a decision.