WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Posts: 6
Registered: ‎01-04-2018

Cannot link Wemo to Google Home & Wemo says it is a Google problem

On December 1st, WeMo's Remote Access went down. I along with others were "unable to enable Remote Access."  While trying to troubleshoot the issue, I "unlinked" my WeMo from my Google Home.  At the time I did not know that the issue with Remote Access was on WeMo's end.  WeMo fixed their Remote Access problem the next day, December 2nd.


Ever since Remote Access has been fixed, now over 48 hours, I have been unable to "relink" WeMo to Google Home.


  • when I try to relink Google Home & WeMo, Google Home sends you back to the WeMo app (the top of the page says:  "oauth.xwemo.com") which then says:  "A network issue occurred."
  • Next it says to enter my Wi-Fi network & Mac Address of one of my WeMo devices.
  • Then WeMo says:  "Hmm. We can't find a match."  Try again, which I do.
  • then WeMo says:  "We can't verify your home network.  Please try again after 10 minutes,"  or you can call WeMo, which I did and got the unacceptable response that it is a Google problem, after the rep asked me a few questions like were my switches working on the WeMo app, I said yes, and WeMo says, then the problem is on Google's end.

Again, each of these pages says at the top:  "oauth.xwemo.com".  Sounds to me like a Wemo website, which would mean a WeMo problem, not a Google problem.  So I ask the customer service rep about "oauth.xwemo.com".  Who owns it?  She's says never heard of it, don't know anything about it.


Seriously??  This is a Google problem and you don't know anything about the authentication process and where it sends you?  Maybe this is Google's problem, but it is strange that problem didn't start until WeMo's Remote Access when down.  Sounds very coincidental to me.


This is not my first issue with WeMo, why should I have so many issues with WeMo, when it was supposed to simplify my life not stress it.


I've probably tried to relink the devices 50 times in the last 48 hours with the same annoying result.  IFTTT works, but you can't group your devices by room to turn off all at once or I wouldn't bother with WeMo.


Would love to know if anyone else has experienced this problem and what they've done to solve it, if they did. 


Posts: 1
Registered: ‎12-03-2018

Re: Cannot link Wemo to Google Home & Wemo says it is a Google problem

Sounds similar to what I just went through with the same time frame. I too unlinked and got the oauth.xwemo.com when I tried to relink. I went through the process of entering network and MAC address of device. When the two-minute timer was on, I clicked the switch on a WeMo Mini and it never got recognized so the timer would run out.


Magically, it just ended up linking yesterday, without me doing anything. My Wemo devices are showing again on Google Home but whenever I try to turn them on or off, I get a something went wrong message. I uninstalled and reinstalled Google Home, Google Assistant and WeMo apps on my phone, checked that firmware was updated and still nothing.

Posts: 6
Registered: ‎01-04-2018

Re: Cannot link Wemo to Google Home & Wemo says it is a Google problem

Failed to mention the following.


But, yes twice I got the two-minute timer, tried every light switch in the house (the timer will let you reset) and none of my mini’s or switch’s were recognized.


I also uninstalled my Google Home and Assistant apps, uninstalled WeMo app, factory reset my Google Home & Mini, and unplugged my router to reset it too.  Plugged the router back in first, waited till it was up and running and then reset up my Home & Mini and reinstalled all my apps.  Made sure all firmware was up-to-date too.


None of that work helped.  Not sure what else to try.

Posts: 130
Registered: ‎12-12-2017

Re: Cannot link Wemo to Google Home & Wemo says it is a Google problem



We recently had problems with the Wemo Remote Access, but our engineers have already fixed it. If you'll still encounter the same issue, we suggest that you try to power cycle your router and see if you'll be able to link your Wemo devices to Google.


If not, we'll endorse your case to our Escalation Engineers for further assistance. Please send us an email at Wemocares@belkin.com with the following details and the link to this community thread for reference.

  • Full name
  • Username
  • Phone number
  • State/Country
  • Wemo device model number and firmware
  • Wemo app and mobile OS version
Jan - 22019
WEMO Technical Support
WEMO Maker Inventor
Posts: 1,702
Registered: ‎06-14-2014

Re: Cannot link Wemo to Google Home & Wemo says it is a Google problem

Power cycle our router?  That would be one nasty problem - was it a virus in your cloud servers?  If you've done something that let a problem into our routers or our home networks (and it's quite possible to do so - e.g. Cisco's warning of the the NSA exploit that, like wemo, uses UPNP) I hope you'll be doing more than encouraging us to restart our routers.  What happens to  customers that aren't following this community?