WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Posts: 2
Registered: ‎03-07-2019
Accepted Solution

Cannot see light switch network

I have a belkin wemo light switch. I recently changed routers, so I needed to connect the switch to the new network. 


When I went to my settings (iPad & Android phone) I could not see the light switch network. I only saw my home internet network. I tried holding the switch for 20 seconds with no luck. I then tried for 30 seconds with no luck. I tried shuting the power off and turning it back on after a couple minutes. Still nothing. The only thing I get is a blinking amber light. 


I am able to turn the light on/off manually. 

Posts: 15
Registered: ‎02-14-2019

Re: Cannot see light switch network




Hi there. A blinking amber light means the Wemo mini is currently not connected to a WiFi network. Since you recently changed routers, you will need to restore the Wemo device to its factory default settings and reconfigure it with the settings of the new router. This link will guide you on how to do it. Please do keep us posted for any updates afterward.






Rowena_B 22017
WEMO Technical Support

Posts: 2
Registered: ‎03-07-2019

Re: Cannot see light switch network

This worked. Mahalo!