WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Posts: 1
Registered: ‎03-07-2015

Connection Problem http:


I have a HD NetCam and a Sansumg S5. I bought the camera 9 months ago and everything seemed to work ok until in December I updated the Firmware. After that, the camera was offline forever.


When I power up the camera, everything works fine, I connect to the camera to configure, I click continue, when It says Camera Preview this message appears: http: The page is unaveilable. Unable to connect to camera.


I already (1) reset the camera several times, (2) reset the router several times, (3) changed the password and connection channels (1, 3, 6 and 11 at 2.4 ghz)


Can anyone please help me?


Thanks in advance for any ideas.

Posts: 223
Registered: ‎05-24-2014

Re: Connection Problem http:

Hi David! Have you tried to relocate the router? Maybe you can plug it in the same room where the router is located and observe the connection. I suggest to try another reset following the steps on this article, http://www.belkin.com/us/support-article?articleNum=8043


Can you also share a screenshot of the error message?



Posts: 4
Registered: ‎03-09-2015

Re: Connection Problem http:

just read manual.

For factory default reset, you need to press a pin and hold 20-30seconds

Posts: 1
Registered: ‎07-10-2018

Re: Connection Problem http:

I am having the same problem. I have tried everything including 20 sec reset. 

Error says this page isn't working didn't send any data.

It has worked fine until now. No changes were made, no new stuff, no moves. Just quit working 

Posts: 167
Registered: ‎12-12-2017

Re: Connection Problem http:

Hi, Sundberg0420,


Allow us to take a look into this. May we know what is the OS of your handheld device? Have you tried to access the Netcam using the web browser? If you haven't, please give it a try. You may also try to set up the Netcam using a different handheld for further isolation.

Jan - 22019
WEMO Technical Support