WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 4
Registered: ‎09-10-2017
Accepted Solution

Echo turns APP light on/Green, but not the actual LIGHT on.

[ Edited ]

Everything setup with echo dot and when asked to turn light on it responds with a sucess and the WeMo APP on the phone turns the light green but the actual light does not turn on.

 

I can make it work by telling echo to turn light on. Then I have to use the phone app to turn it off. Then tell echo to turn it off. Then it will work as it should after that but I have to repeat this process every day.

 

Any clues to whats going on?

 

Thanks for any advice offered.

Moderator
Posts: 154
Registered: ‎01-05-2016

Re: Echo turns APP light on/Green, but not the actual LIGHT on.

Hi, Kennyh327. Allow us to check on this further. What Wemo device are you using? Make sure that the Wemo app is running on its latest firmware. Also, place the Wemo device to a location where it can get at least 2-3 signal bars from the router.

Chris-21499
WEMO Technical Support
Posts: 4
Registered: ‎09-10-2017

Re: Echo turns APP light on/Green, but not the actual LIGHT on.

Using this with WeMo Link and 3 bulbs. All with the same problem. The Link and all bulbs are within close range of router and getting full wifi signal. Besides wemo app I'm also using Automation Manager but problem persists with that uninstalled as well.
Highlighted
WEMO Maker Inventor
Posts: 1,298
Registered: ‎06-14-2014

Re: Echo turns APP light on/Green, but not the actual LIGHT on.


Kennyh327 wrote:
Besides wemo app I'm also using Automation Manager but problem persists with that uninstalled as well.

That's disconcerting - the "uninstalled" part I mean Smiley Happy.

 

Are you using the dimming or sleep functions?  That bulb behavior is a bit tricky and the last time I checked (which admittedly was quite some time ago) the belkin app didn't handle it properly, it's possible the echo isn't either.  If so, try changing the brightness level after turning on the bulb, or using the brightness control to turn it on.  If it works that could confirm it as a belkin or echo bug.

 

I think the wemo link is reporting the bulb state is on 'cause the belkin app is showing it as green (that is the symptom of the fade bug - reporting on but it's not), if there's any doubt you can also confirm looking in AutomationManager UI and at its log which will show the state being reported.

 

Posts: 4
Registered: ‎09-10-2017

Re: Echo turns APP light on/Green, but not the actual LIGHT on.

Automation manager is the ONLY reason I keep these buggy wemo products.
I rarely use the dimmer and never the sleep function.
I don't know what I'm talking about but I just don't think it could be an echo problem as it does everything it is suppose to and confirms success.
Has to be a Belkin problem and I wonder if I'm the only one, then maybe a phone problem.
But trying again today echo confirms success with one of my lights, WeMo app widget turns green, but the light does not turn on. So using the WeMo app to turn the light on and off a few times, then it will work with Echo. Am I the only one?
WEMO Maker Inventor
Posts: 1,298
Registered: ‎06-14-2014

Re: Echo turns APP light on/Green, but not the actual LIGHT on.

Doesn't look like belkin is ready to "help you with this challenge"...

 

An alternative is to use AutomationManager as a hub (WemoServer) if you've got a spare android phone.  Once it's running in WemoServer preferences enable "Echoi/Dot discovery", then  you can use the "Manage Devices" menu item to bridge the wemo bulbs.  Run Alexa discovery to find them and it'll be able to control the bulbs locally rather than going through the belkin cloud service. 

Posts: 9
Registered: ‎08-01-2015

Re: Echo turns APP light on/Green, but not the actual LIGHT on.

Instead of telling echo to turn a wemo bulb on tell her to set it at a level. 10% or any percent. Alexa set my lamp(or whatever name) to 50%.
Posts: 4
Registered: ‎09-10-2017

Re: Echo turns APP light on/Green, but not the actual LIGHT on.

Thank you. That works.
WEMO Maker Inventor
Posts: 1,298
Registered: ‎06-14-2014

Re: Echo turns APP light on/Green, but not the actual LIGHT on.

Interesting - that's a symptom of that same issue.  If I were to guess it'd be that belkin implemented the echo skill for bulbs to dim them to 0 over a short period vs toggling them off immediately.  Poor testing on their part not to catch the original as a bug, really poor testing not to catch the "turn back on" problem!