WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Posts: 1
Registered: ‎07-11-2018

FW upgrade issue for Wemo socket

[ Edited ]

I'm currently running two Wemo sockets with FW version: WeMo_WW_2.00.11059.PVT-OWRT-SNSV2

Since about half a month ago, the WeMo app on my Android cell phone keep saying there is a new FW available. The new FW version it shows in the upgrade note is WW SC 11057 PVT.

Isn't this older than what I'm currently running? (11057 < 11059)

I tried to upgrade both, but after the long process done, the FW still shows 11059. The 11057 notice still keep showing up everytime I launch the WeMo app, even though the app said "Upgrade success"

I tried to upgrade while my cell phone connects to the same network where both scoket are connected to (The guest network on the Google WiFi), still no success. (I has no issue when setting up both sockets on the guest network, so I don't think it's the network issue)

I tried to reinstall the Wemo app on my cell phone, same thing happened.


Anyone has any idea?



Posts: 126
Registered: ‎12-13-2017

Re: FW upgrade issue for Wemo socket


Hello charco,


Is this the model number of your Wemo Switch?. What's the Android version of the handheld device?
Have you tried using a different handheld device? You may also try power cycling the Wemo Switches and open the app once again.


If the issue persists, feel free to shoot us an email via WemoCares@belkin.com along with the following info: Complete name, phone number, location (city/state), username and link to this community post

Reynaldo - 22029
Wemo Technical Support