WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
WEMO Maker Inventor
Posts: 1,796
Registered: ‎06-14-2014

Re: SOLVED! Google Home unable reach WEMO

@trafferty wrote:

"...escalated up to Level 2 and he asked for my WiFi SSID.  He was able to find an entry for my network on his servers and then looked up the MAC address of my Wemo plug and found that it was showing up on other people's networks also (in their database).  He had to delete my network from their servers and told me it would take 24-48 hours before I would be able to set it up with Google Home again..." 

@belkin, holy crap, you all know about this problem there and still do nothing?  Why did the technician NOT OPEN A HIGH SEVERITY DEFECT AND NOTIFY US of the exposure of our devices to other users?  When will this be fixed?!!!


And this was done accidentally (server bugs) at Belkin.  I shudder for the naive customers buying low cost China sourced cloud-only IoT devices who have no idea of the risk they're taking running them inside their personal network.  At least wemo's can be used only on the local LAN and your router used to block them from the internet.  I hope we're not all victims of DDOS attacks from those devices some day Smiley Sad.  Home automation should stay IN home!



Reliable and secure (Belkin cloud-free) home automation and remote access:
Posts: 1
Registered: ‎01-11-2019

Re: Google Home unable reach WEMO

Been having this issue for a couple weeks now. It started in december but I knew I was moving in the new year so I figured I'd try to start from scratch and deal with it then... well, its then and nothing has changed. This has gone from annoying to downright insulting. Every help topic I read is just community "moderators"  asking if people have their device plugged in, what color the led is, and if the firmware is up to date. I'm sorry, but at some point thats just not helpful at all. 1000 posts with issues and 2000 replies asking if people turned it off and back on with about 5 "real" help posts in between.


I de-linked, deleted and rebuilt my whole google home setup, I've updated the firmware (though it sat at "updating" so long I'm not sure if it even worked... which is its own issue), I've tried multiple devices, uninstalling and reinstalling the app and STILL google home tells me "wemo is unavailable" every time I try to use it. I can turn things on and off through the wemo app, but thats not why I bought these devices. Theres a dimmer that I no longer own that google home can still see but I can't manually remove from my account. This whole product line is an absolute joke. I might as well have bought the no-name crap off amazon for half the price... they might be a security nightmare but at least they cost 1/3 as much when they end up not working.


Has anyone come up with a real fix to this issue? All I see is people talking in circles with no response from Belkin

Posts: 1
Registered: ‎01-12-2019

Re: Google Home unable reach WEMO

So I am having the same problem. It started about a week or so ago. Wemo app works and I can control devices from that app, so I am sure all is good. I am wondering whether it has anything to do with me Setting up and using Apple Home Kit. So along with my question of how to get my google mini home assistant to manage my Wemo mini Plug. I have 3 of them and neither of them work. Does this have anything to do with having them set up with Apple Home Kit. You may ask why have both google mini and apple controlling the devices, but sometime my iphone isn't handy, it is just easier to ask google to turn on or off of the light, and right now it isnt' doing either, and say's exactly what the post states.

Posts: 4
Registered: ‎03-20-2019

Re: Google Home unable reach WEMO

I discovered that my Pixel has "Google VPN" automatically turned on, which would cause my Verify Wemo attempts to fail (including having to enter Network and MAC addresses).  As SOON as I turned off the VPN, it worked and everything linked up.

Posts: 1
Registered: ‎03-27-2019

Re: Google Home unable reach WEMO

So I thought I'd share my experience just to see if it rings any bells with the people that program/maintain the cloud servers. I'm in a home that is under renos. That power is being cut off all the time due to construction. The only way I've been able to get wemo and Google to communicate after a power loss is to:
1. Remove wemo from google home account.(you can use any device currently setup with the google home app in your network)
2.Get a new device that has never had the wemo or google home app set up on it, and/or your network(I'm using all android BTW)
3.Download wemo app on new device.
4.Go to any of your Wemo products and do a reset on it. Use the wemo app on new device to setup the reset wemo. Make sure you complete the whole process including getting Remote access enabled. Be patient with the last part. It will probably take more than one try to get remote access.
5.Download Google home app on new device. Setup, and relink wemo once again. This may also take patience. You may need to get the mac address off the wemo device you intend to toggle durning linking.
After all this, I usually wait an hour before asking Google to do anything.
I've done this 3 times successfully. I'm out of androids to setup my wemo now.
Belkin, will you please send me some more androids to setup my wemo?