WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 1
Registered: ‎11-30-2016

Holiday Lights Causing WiFi Interference & Disconnections

Hey all,

 

I've had my WeMo switches working flawlessly now for at least a year and a half.

 

Two weeks ago, when I put up our holiday lights outside my house, my WeMos started disconnecting from my WiFI network.

 

Last year, I was using traditional holiday lighting and I didn't have this problem. This year I switched to LED holiday lights.

 

I did some app troubleshooting, but ultimately I realized the LED holiday lights were interfering with my WeMo switches (which run on my 2ghz WiFi network).

 

I changed the broadcast channel in my Airport Express and the problem was instantly solved.

 

My WeMos are now back to perfect operation.

 

Just a heads for anyone having problems staying connected!

Highlighted
Posts: 226
Registered: ‎05-04-2015

Re: Holiday Lights Causing WiFi Interference & Disconnections

[ Edited ]

Hello JDT612

 

It's great that you have raised awareness of this issue, and published your excellent remedy.

 

Most modern electronic devices use what is known as switch mode power supplies these days because they are efficient, small and light-weight and above all cheap to manufacture. This type of power supply as you have discovered, can produce a lot of radio frequency interference. This can be demonstrated by holding a radio on medium wave a few inches from one of these power supplies. You will hear nothing but interference.

 

I had a similar problem with one of my WeMos forever dropping off line and reconnecting just as yours did. This I discovered through looking at my router's log. The problem was that I had my 'phone charger plugged into the socket adjacent to the WeMo. My solution was simply to move the charger to a more remote socket. Changing the WiFi channel as you did would probably have fixed the problem too but the channel was the strongest and I wanted to stay with it.

Regards

Pete