WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Posts: 1
Registered: ‎01-10-2018

How I got my Wemo Dimmers to connect to WiFi

The solution I found is at the bottom of the post, if you want to skip.  I put the extra details in case others have tried the same things, and are trying to find similar situations.


So, I purchased 2 new Wemo dimmers and I had a terrible time trying to connect them to WiFi.  I tried using both Android and Apple devices.


To give a bit of background info, I have a higher-end ASUS router that does dual-band routing, as well as lots of advanced options.  I'm also quite technologically savvy as I work in the IT field, so I generally know what I'm doing when it comes to my tech.  Most of my devices run on the 5Ghz network, but I have a few older devices that need the 2.4Ghz network.


Every time it would try to connect over WiFi, it would either drop the network on the device and try to connect to a different one, messing the process up, or it would tell me that it couldn't connect to my home network.  I tried all of the basic recommendations about turning off smart network switch on my phone, resetting the dimmer switches, dropping all other networks save for the Wemo one, etc...


What I ended up trying was flipping my 2.4Ghz network to open and retrying the setup.  That ended up working for both dimmer switches.  However, leaving one of my networks open isn't the ideal solution.  I figured I would not broadcast the network name and enable MAC filtering to prevent anyone from just hopping on and using the network.  However, once I did those things, I couldn't get the dimmers to connect to the network after that.  I verified the network name multiple times, but it just wouldn't connect.  I also made sure that I added the right MAC addresses to the filtering list and ensured that it was set to only allow the ones in the list.  Still no dice...


From there, I changed the network security to to WPA, and re-ran through the setup.  Still failed on connecting to WiFi.  I changed my password to not use any special characters (I use $,#, and ! in my network password).  Re-ran through the setup, and it finally worked.


I haven't bothered to test if WPA2 security will work, but I suspect that it will, as long as you don't use special characters (and maybe uppercase letters) in the password.  Since I got them working after 2 days of toying with them, I didn't want to break it again just to test it.  I might test this theory if I end up getting additional switches though.


For whatever reason, it seems like the dimmer switches cannot connect to the network if the password contains special characters.  I know quite a few people have been hitting this same pain, and hopefully this is the solution for you guys.


As a last note, I had greater success running through the dimmer switch setup using my iPad over my phone.  I simply flipped off auto-join for all other networks save the one dimmer switch I was working on setting up at the time.  I ended up just using my iPad for subsequent setups.

Posts: 1
Registered: ‎07-31-2018

Re: How I got my Wemo Dimmers to connect to WiFi

I don't have any special characters. It still does not connect.