WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Posts: 4
Registered: ‎04-20-2017

Issues With Setting Up Wemo Link

I'm having issues while setting up Wemo Link, more specificaly when it needs to connect to my network and establish remote control it connects to it's own network instead again, I have no issues setting up other Wemo hardware like Wemo Insight and Wemo Switch, Link is pretty much next to my router and fairly close to bulbs, I've tried everything, including hard reset but to no end.

Moderator
Posts: 555
Registered: ‎06-17-2015

Re: Issues With Setting Up Wemo Link

@Roberto
Right after you try to connect the Link to your network, does it give you any error message? If the setup SSID does not disappear, that means the Link was not configured properly.


What's the status of the LED on the Wemo Link? Is it possible for you to try another smart device for the setup?

Thaddeus - 14850
WEMO Technical Support
Posts: 4
Registered: ‎04-20-2017

Re: Issues With Setting Up Wemo Link

No error messages, save on one occasion where it said it failed to connect to my network and asked for a password, once I did all that it conected to itself again instead of my network.

 

I tried with Samsung Galaxy A6,LG G4 & Moto Z Play, on several different routers and networks, no go. It flashes amber/green during the set up, solid green once it connects to itself, the light turns off after that. As I already mentioned, I had no problems setting some of their other products.

Expert
Posts: 47
Registered: ‎07-06-2016

Re: Issues With Setting Up Wemo Link

Understood. We would like to have our 2nd Level Team further assist you with this. Just send us an email at WemoCares@belkin.com with your contact details (phone number, location) and the link to this thread. 

Fate – 21474
WeMo Technical Support