WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 16
Registered: ‎03-11-2016

My router started blocking Wemo devices access due to security reasons

I have a synology router running my home network. And just yesterday it started blocking my wemo devices from accessing IP address 4.2.2.2 for security reasons.

 

Is this normal behavior for the devices, or did something change with them?

 

It is possible that the threat data bases that synology gathers may have been updated and now include this...

Moderator
Posts: 2
Registered: ‎02-12-2019

Re: My router started blocking Wemo devices access due to security reasons

Hi, ScottChapman. Let us have a closer look at this. This is a bit odd. Are there other devices, aside from the Wemo that are also affected? Did you do anything to the router, like updating its firmware? Also, are the Wemo devices’ firmware are up-to-date?

 

 

Gregory - 25337
WEMO Technical Support

Posts: 16
Registered: ‎03-11-2016

Re: My router started blocking Wemo devices access due to security reasons

Firmware on the router didn't update. The feature on the Synology router uses a bunch of external databases (including Google's) to determine what behavior is bad. I don't really know what the source is but I could perhaps contact Synology and see if they might be able to narrow that down.

 

However, you guys should know if that IP address is one you expect the switches to use in their normal behavior?

Posts: 319
Registered: ‎03-08-2017

Re: My router started blocking Wemo devices access due to security reasons

4.2.2.2 is one of the Internet root DNS servers. It’s not uncommon to configure a network appliance to use one of those as a last resort. However, most endpoint devices will only use whatever they get from DHCP, which in home environments is usually your router or modem.

Have you been experiencing any other internet issues at home recently? “Server address could not be found” or similar errors?
Posts: 16
Registered: ‎03-11-2016

Re: My router started blocking Wemo devices access due to security reasons

Yea, my router sets up clients to to use it as the DNS. WOuld the devices have gone directly to that on it's own?

 

Not experiencing any issue during that period of time.

Posts: 2
Registered: ‎03-04-2019

Re: My router started blocking Wemo devices access due to security reasons

Interesting. Me too. Just yesterday, Sunday Mar. 3, 2019, I opened the Wemo app to check on things (I do that once in a while just to make sure things are still ok) and it said new firmware available. I let it update and shortly after I started getting warnings from my Synology router that it is blocking requests from my Wemo devices to DNS server IP 4.2.2.2. I got about a hundred warnings total from my Wemo devices trying to access it before I realized it.

There were no/zip/0/nada changes to anything on the network. I don’t use 4.2.2.2 as a DNS server in my DHCP nor is it used in any reserved or static IPs anywhere on my network. Wemo devices have a reserved IP that doesn’t change and they have been fine for literally years.

My devices are all up to date with firmware for their age and type and range from 2.00.11057; 2.00.11299; 2.00.11326. This only started yesterday after my update. I have never seen it before.

It looks like they are trying using a DNS have not configured. Maybe the firmware is trying to ‘help’ by picking a DNS server that is normally ‘good?’ That would not be appropriate however. They need to follow DHCP rules.

My temp fix it to allow the 4.2.2.2 IP through.

Thoughts?
Posts: 2
Registered: ‎03-04-2019

Re: My router started blocking Wemo devices access due to security reasons

[ Edited ]

Warning email from router was:
The connection from Wemo-Device1 to 4.2.2[.]2 has been blocked for security reasons(Malicious).

Sent from your Synology Router- HomeRouter

Searching for Synology and 4.2.2.2 I found this dated yesterday also:
https://www.reddit.com/r/synology/comments/ax7wpp/synology_rt2600ac_srm_safe_access_now_blocking/

Might Synology safe settings be blocking? Even if it were being blocked, 4.2.2.2 is nowhere in my network and should not be accessed by wemo. If I understand correctly, if one (recursive) DNS server doesn’t have the address of interest, it queries other DNS servers but it itself responds to the original request.

Thoughts?

Highlighted
Posts: 1
Registered: ‎03-14-2019

Re: My router started blocking Wemo devices access due to security reasons

My Synology router has also begun blocking my Wemo from reaching 4.2.2.2.

How do I get my wemo to use the DNS that my router provides via DHCP?

 

Posts: 1
Registered: ‎03-15-2019

Re: My router started blocking Wemo devices access due to security reasons

Same here. Some WeMo devices are trying to connect to 4.2.2.2, but not all of them. I have 6 WeMo devices and only three of them trigger the block. 

WeMo Devices that are being blocked by Synology's Safe Access are

  • Light Switch
  • Insight

WeMo devices that are not raising flags are

  • Dimmer
  • Switch
Posts: 2
Registered: ‎03-26-2019

Re: My router started blocking Wemo devices access due to security reasons

My Synology switch has likewise started hindering my Wemo from achieving 4.2.2.2.

How would I get my wemo to utilize the DNS that my switch gives by means of DHCP?