WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 1
Registered: ‎09-23-2018

Unable to configure Mini Plug to Wifi Network

I have been trying over and over to get Mini Plug on the July 25th firmware to connect to my 2.4GHz network. All of this started because of the firmware update.... and I had to reset the plugs and now I can't get them to take the Wifi settings no matter what I do. My iPhone is connected to the same 2.4Ghz network and I connect wifi to the plug, the app prompts me to pick a network which I do, and basically says it connects only to not connect and have to start over and over and over.

Posts: 2
Registered: ‎09-23-2018

Re: Unable to configure Mini Plug to Wifi Network

Resolved: Here is what worked for me: (issue of wemo Mini not showing in wemo app and/or unable to connect or reconnect to WiFi.)

1. Make wemo “forget network”
2. Unplug wemo Mini (if you have more than one, unplug them all. You’ll reconnect only one at a time only after each one set up successfully.)
3. Uninstall Wemo app
4. Go to phone WiFi settings, select forget network for your 5ghz (make sure you are on 2.4ghz only)
5. Router settings: choose Router channel 1 or 6 or 11. I used 6. (2.4ghz WiFi was on channel 10 but I changed to 6 to get Wemo to work.)
6. Reboot router
7. Plug in wemo Mini while keeping button pressed until Amber (orange) light comes on- (must be pressing button already before plugging in.)
8. Install wemo app
9. Go to WiFi settings on phone
10. Select the wemo Mini plug as WiFi (for now)
11. Open wemo app
It will find the plug and ask questions:
12. You’ll name it- (if you already had connected to smart device before like google assistant, enter same name as before.)
13. Do NOT choose keep WiFi setting for other wemo devices (deselect that)
14. Hit Next, then select your 2.4ghz WiFi network and enter its password- you can choose “show password” then click next.
15. It should put you back on your WiFi and find the device. (You probably won’t need to reconfigure to google as mentioned previously.)
16. Test it by going into wemo app and turning on or off. (May also want to ask google assistant to turn on and off if you have set up with that too.)
17. If doesnt work repeat all steps- sometimes it takes a few times.
18. Do not choose update firmware at any point in this process unless you like to complicate things.
19. It is possible it will update firmware automatically at some point in which case you may find yourself back here doing all these steps once again. (But at least hopefully with this you won’t have to figure it out all over again!)
20. If you have other wemo minis, after successful- repeat steps for others one by one.
21. You may go back to phone WiFi settings and add your 5ghz WiFi back again and use that.

*This is what worked for me and hopefully will help others. Depends on individuals specific set up, mine included dual router, but may skip router steps above if not applicable.

Steve in GA
Highlighted
Posts: 311
Registered: ‎03-08-2017

Re: Unable to configure Mini Plug to Wifi Network

I applaud your tenacity. Belkin, what’s being done to remove the need for a 21-step process to set up a device?