WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 2
Registered: ‎01-15-2016

WEMO Switch NOT DETECTED

I bought my switch a few months back.  I Installed it today and am having an issue.  It seems to work for a little bit and the always go to Not Detected.  I reset it a few time, reintalled it a few times, reinstalled the app a few time.  And always the same thing.  It just seem to lose the router, and I know it's not my router because everyting else works. I have a the WEMO LED light and have never had an issue with it.  It comes back perodically but always loses it.  So something leads me to beleave something isn't right with the switch.

 

I had a Mac airport extreme...I can't see this being an issue as the other WEMO product works.

 

Anyone else in the same boat?

 

Thanks

Mark

Posts: 2
Registered: ‎01-15-2016

Re: WEMO Switch NOT DETECTED

Sorry should say it's a light switch

Thanks again
Mark
Guy
Posts: 1
Registered: ‎01-15-2016

Re: WEMO Switch NOT DETECTED

I have the exact same problem! Don't know what to do!
Expert
Posts: 259
Registered: ‎07-18-2015

Re: WEMO Switch NOT DETECTED

 

Hi Archcat. There are different factors that would cause this to happen. Let check some few things here for us to find out what is causing the trouble.

 

Please make sure that the light switch is getting at least 2-3 wireless signal bars from the router. You may check out this video on how to install the device: https://www.youtube.com/watch?v=W3ML4zPMyHE

If its doing the same thing, you may do a factory reset and configure the device again. You may also uninstall and reinstall the WEMO app.

 

@Guy. Were you able to install the switch before? If you were, you can do the same steps as I what I have provided to Archcat.

 

 

More info here: http://www.belkin.com/wemo/lightswitch WeMo Light Switch allows you to turn the lights on or off from the other side of the house, or the other side of town. Here is a step-by-step video that shows how easy the WeMo Light Switch is to install
Posts: 6
Registered: ‎01-21-2016

Re: WEMO Switch NOT DETECTED

I'm seeing the same problem with my 5 WeMo Switches and 1 Belkin NetCam HD. They randomly go "Not Detected" in the WeMo app and never come back unless I reset them. Here are some other interesting details about my problem that you may look into:
My devices ONLY show as Not Detected if my iOS phone is connected to the same Wifi network as the WeMo devices.
If I turn off Wifi on my phone so that I am using only the cellular connections, all the devices come back. If I then reconnect my phone to Wifi, the same devices go back to Not Detected.
If I connect my iPhone to another Wifi network, all of my devices are OK, but as soon as I reconnect to the same Wifi as my WeMo devices, the same ones go to Not Detected.
All rules that I have created in IFTTT and in the WeMo app continue to work even on devices that show as Not Detected.
I've done some work with my router and assigned specific internal IP addresses to each WeMo device (didn't fix anything). My router ALWAYS thinks that all of the WeMo devices are connected - even when the WeMo app shows them as Not Detected. This leads me to believe that this is a WeMo APP problem and not a device problem.
Archcat: Try turning off Wifi on your phone and see if the devices show up in the WeMo app. If this brings them back, you will have access to all the IFTTT and WeMo rule creation capability.
Posts: 15
Registered: ‎01-15-2017

Re: WEMO Switch NOT DETECTED

I have 11 WeMo light switches and 2 WeMo wall outlets. Since I've installed them they constantly go offline. I have 2 routers and 4 access points (each has 2.4 and 5 GHz SSIDs). Anyways all my other devices including my 5 Nestcams, 5 mobile devices, Xbox one, Apple TV, Roomba, etc all have strong connections and never go offline. These switches constantly show Not Detected at random times and seem to connnect again at a later time on their own. After this most recent update, 3 of the 11 had to be reset and none will allow me to complete the setup process. I get a message saying connection to the switch was lost during setup. I'm an IT professional with many years of experience, some directly in the smart home space. Im seriously considering switching all my WeMo switches out for the Insteon SmartLinc Dimming switches. Family of mine have these and they work flawlessly. They're $50 each though so not sure I want to undertake that expense already having spent so much on these POS WeMos. Ugh.
Posts: 1,055
Registered: ‎12-08-2014

Re: WEMO Switch NOT DETECTED

Have you reserved IPs for your Wemo's?  
I run over 150 between two sites and aside from bulbs dropping off the Wemo Link from time to time all of my switches are solid.  I do primarily use Automation manager though.
Both networks have multiple APs, switches & repeaters beyond the core router

 

Mbaturin wrote:
I have 11 WeMo light switches and 2 WeMo wall outlets. Since I've installed them they constantly go offline. I have 2 routers and 4 access points (each has 2.4 and 5 GHz SSIDs). Anyways all my other devices including my 5 Nestcams, 5 mobile devices, Xbox one, Apple TV, Roomba, etc all have strong connections and never go offline. These switches constantly show Not Detected at random times and seem to connnect again at a later time on their own. After this most recent update, 3 of the 11 had to be reset and none will allow me to complete the setup process. I get a message saying connection to the switch was lost during setup. I'm an IT professional with many years of experience, some directly in the smart home space. Im seriously considering switching all my WeMo switches out for the Insteon SmartLinc Dimming switches. Family of mine have these and they work flawlessly. They're $50 each though so not sure I want to undertake that expense already having spent so much on these POS WeMos. Ugh.

 

Posts: 15
Registered: ‎01-15-2017

Re: WEMO Switch NOT DETECTED

I do have all of them on Reserved IPs. My next step is to release them all, then reserve the new IPs because I fear after this most recent update some are stepping on others toes somehow.
Posts: 15
Registered: ‎01-15-2017

Re: WEMO Switch NOT DETECTED

Also, what's Automation manager?
Posts: 1,055
Registered: ‎12-08-2014

Re: WEMO Switch NOT DETECTED

Link is in my signature. You might also want to reboot router if you can. Just to rule out the easy stuff.