WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 1
Registered: ‎12-08-2015

WEMO app can't find devices anymore

Set up my WEMO switches to turn on/off lights and everything worked fine. Then yesterday the lights did not go off per the rules. Launched the WEMO app and it can't even find the devices or they show up as "Not Detected." They don't show up in the WiFi list,  so I can't even re-sync everything all over.

 

This is the same WiFi network. No changes were made.

 

How can I get the WEMO app to see the devices again? Or how do I reset the WEMO to start from scratch?

Posts: 1
Registered: ‎12-08-2015

Re: WEMO app can't find devices anymore

I am having exactly the same problem and cant find solution to the problem...one thing i have discovered is the 'quick switch' app (which i set up before losing connection) still works even though the wemo app has lost all connections! Makes me think it is the app that is having problems not the plugs
Posts: 14
Registered: ‎05-15-2015

Re: WEMO app can't find devices anymore

I've been having the same exact issues since the last firmware update.  I see there was a new update today.  So far that hasn't helped either.

Expert
Posts: 108
Registered: ‎06-17-2015

Re: WEMO app can't find devices anymore

[ Edited ]

Hi All,

 

I suggest you follow the steps on these links:

 

WEMO device not in App

Manually resetting or restoring the WEMO Insight, Switch and Motion

 

Ann_18678
WEMO Technical Support

 

Posts: 1
Registered: ‎12-09-2015

Re: WEMO app can't find devices anymore

I've now done this multiple times for both of my switches and also deleted and re-downloaded the app. Nothing is working. Now changes to my network.
Moderator
Posts: 144
Registered: ‎06-17-2015

Re: WEMO app can't find devices anymore

Be sure to connect the WEMO devices and the mobile device (that has the WEMO App) to the 2.4 GHz WiFi network. If the mobile device is connected to the 5 GHz network the WEMO app won't be able to detect the WEMO devices. This article could be of help: http://www.belkin.com/us/support-article?articleNum=8182

 

Email us at WEMOCares@belkin.com if the problem still exists.

Zeb_10124
WEMO Technical Support
Posts: 3
Registered: ‎03-28-2015

Re: WEMO app can't find devices anymore

I see the same thing.

 

I got two devices working fine, but the have never consistently and reliably been found.

 

At least 30% of the time, one or both of them cannot be found.

 

All my software is up to date, all devices are on the same wifi (except the iOS device hosting the App), and everything ours powered on.

Moderator
Posts: 305
Registered: ‎06-29-2015

Re: WEMO app can't find devices anymore

Thank you for sharing your experience, SkippyRiver. Let's sort this out together. Was this working fine before? What steps have you taken so far? We suggest that you do the following:

 

  • Force closed the app
  • Uninstall/reinstall
  • Reboot your handheld device

Once you're done, check if your app can now detect your WEMO device. Update us the results.

Dennis - 20702
WEMO Technical Support
Posts: 1
Registered: ‎03-01-2016

Re: WEMO app can't find devices anymore

I'm having the same issue.  I feel it's with dual band routers.  

 

I have connected the WEMO's to the 2.4ghz SSID.  The WEMO's connect and show that they are connected on the devices themselves.  I can confirm they are connected via the router via the 2.4ghz SSID.

 

However, the iOS WEMO app cannot detect the devices.  Yet I can enumerate them on my router.  

 

 

I've even disabled the 5ghz SSID to see if that helped and it didn't.

 

If I move the devices back to a 2.4 router (single band) ... then it enumerates fine and the app can see them.

 

Any ideas?

 

I have two dual band router's I've tried this with.

 

(And yes ... the bands have different names ... and yes the iOS device is connected to the same 2.4ghz SSID).

 

They are both Linksys ... one is the new EA8500 and the other is the WRT1900AC.

 

Do you have an enumeration app available from a desktop to validate they are there?

Moderator
Posts: 168
Registered: ‎06-30-2015

Re: WEMO app can't find devices anymore

Let's sort this out, moosery. What's the firmware of your WEMO App and WEMO devices? We suggest to reset your WEMO devices and uninstall and reinstall the WEMO App in your phone. For further isolation, you may also try installing it using another handheld or wireless devices to check if you're getting the same results. 

 

BTW, as of the moment we don't have an enumeration app available for a desktop to be used for validation. 

 

Jay-15354

WEMO Technical Support