WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Posts: 4
Registered: ‎05-03-2017

Re: WEMO app can't find devices anymore

Update:  I powered up my old phone and opened the WEMO app.  That app had a pop up message that the devices needed a firmware update.  I updated the firmware.  Then when I opened the app on my new phone, it recognized the devices.  FORTUNATELY, I had not yet sent back my old phone or I would never have figured this out...

Posts: 3
Registered: ‎05-30-2017

Re: WEMO app can't find devices anymore

I have same issue. Lost two devices. Went through all the steps above but app still won't pick them up. I even added a new plug and went through the config without issue but app won't pick it up. I'm getting really tired of having to do this over and over again. Need assistance asap or I will put out the necessary poor evaluation and recommendations to everyone.
Posts: 3
Registered: ‎05-30-2017

Re: WEMO app can't find devices anymore

Posts: 179
Registered: ‎01-05-2016

Re: WEMO app can't find devices anymore

Hi, beitlerbeitler. What's the OS version of your handheld device? You can try to install the Wemo app on another smartphone, connect it to the 2.4 GHz where your Wemo devices are connected and check if the app can then detect your devices. Make sure to keep the Wemo app up-to-date, as well.

WEMO Technical Support
Posts: 1
Registered: ‎11-28-2017

My idea

I've spent two hours and read this thread and probably 15 others and all I can say is . . . 


WOW I would have never thought it would have been so freaking difficult to set up an extra couple of plugs. I mean really I screw in a hue light  and look at the app for 2 seconds and it's done.  I say that because obviously it is able to get done fairly easily  but  who makes WeMo? Belkin? can't figure it out? REALLY? You need to update your phone and update the device and then you need to make sure you're using a 2.4 ghz wifi and then you need to use someone else's phone to set it up or an old phone of yours and uninstall and reinstall and if you're away from home you're SOL and maybe if all of that doesn't work someone might come and help you but I would bet that someone will give you a 2-4-Hour window sometime next week. And really I don't know what you're setting up but do you really want some guy coming to your house to show you how to screw in light bulbs or plug-in plugs or whatever they're going to do? I might have missed something but I'm sure anyone reading this gets the idea. So if you have gotten to this post and you're still working on it (and probably pulling out your hair ready to throw the device against a brick wall) I have a suggestion. (This is what I finally did.)


1. Take a couple breaths  and then  calmly put devices in package - wrap it all up like it came

2.  Get a return slip from Amazon or go to the store you originally purchased it from

3. Return this horrible device(s)

4. Buy a different device(s)

5.  Come home read the directions set it up have a drink.

At this point I promise you everything will be so much better. And you can come back to threads like this one and make sarcastic posts.😉


I did these things and set my new plugs up in 30 minutes. That includes driving to the store. Now I have 3 working plugs. One WeMo (that I can't get my money back for since I bought it and it worked fine because it was the initiall device) and two others. If you don't have to keep any of your wemos consider yourself lucky because you don't have to keep the app on your phone like I do. Of course I'm guessing eventually I will throw that one away.


This is the first time I've ever been here and probably the last cuz it's WeMo support and unless they somehow take over the world I'm not going to need it again. So y'all have a wonderful day.


Your WeMoless friend (Well almost)

Lynda 😁

Posts: 4
Registered: ‎11-26-2017

Re: WEMO app can't find devices anymore

These things have serious functionality issues. I added another switch recently, now one by one they aren't detected by the app. Tried rebooting, reinstalling and resetting all the devices. Contacted the "Support" people, gave them all my info.... and nothing. Good luck to all the people requiring help. I seriously think they have no idea what's wrong with their products. Several of mine are just fancy manual light switches with pretty blinking lights now
Posts: 1
Registered: ‎12-02-2017

Re: WEMO app can't find devices anymore

So, like everyone else, I pulled my hair out and kept trying to reset and connect my WEMO plug. So here's what you need to do:


1. Reset your WEMO plug as per instructions (unplug for 20 seconds, hold the restore while plugging WEMO back in for 10 sec)


2. Reconnect to your WEMO device to set it up again (check your wifi and connect to WEMO device).


3. Set WEMO up and make sure you leave "Remember Wireless Settings".


4. Go to your device and delete the WEMO app.


5. Go back to your device and re-download the WEMO app.


6. WEMO should be back up. 


7. Open a bottle of a good cab and drink up!

Posts: 1
Registered: ‎12-03-2017

Re: WEMO app can't find devices anymore

I tried everything with my Android phone right down to removing the app after 7 resets to factory default on the Wemo. I acutally had to use an Apple device to get mine up and running. My Android Phone would not find  the device even after it was set up. I had to use my Wife's IPhone to set it up and update the firmware. After that I am able to manage and see my WEMO via Android. 

Posts: 379
Registered: ‎08-08-2017

Re: WEMO app can't find devices anymore

Hi, All. Allow us to have your cases checked with our Escalation Engineers. Please email us at WemoCares@belkin.com along with the following details:


- Phone Number
- Location
- WEMO App version
- iOS or Android version

Jo-Ann - 21744
WEMO Technical Support
Posts: 2
Registered: ‎01-07-2018

Re: WEMO app can't find devices anymore

I isolated my issue to two problems that I believe were related. I think the primary issue was using a Google hub that is dynamic in determining 2.4 vs 5... and I think that smart feature has created other WiFi device parit issues reliant on my iPhone. I broke out an old router that runs a static 2.4 and static 5 isolated signal (two separately named WiFi’s), did a firmware update, and then tried pairing the devices again... no dice. Until I used a separate device (my iPad). I could see on the google WiFi that the devices kept talking to the network even after hard resetting them like 20 times. I deleted and restored app to my iPhone several times, and that never fixed it. Some how the iPhone was retaining the association with the devices even after I was resetting them and deleting/restoring app. This was after turning off the remote support too. It took a new 2.4 dedicated network on channel 2 and a separate new device to get it sorted out. I blame 5Ghz being confused by the google hub router and the Apple wemo app some how holding phantom memory. As you can tell I’m not super tech savvy but I was methodical in my resolution process and this was the only solution that worked after hours of trouble shooting.