WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Posts: 3
Registered: ‎12-30-2017

WeMo Devices Cannot Detect Wifi SSID

[ Edited ]

All - 


I have four Wemo light switches, one dimmer, one switch plug, and one mini switch plug. None are able to detect my Wifi SSID. My router is a Peplink Surf SOHO MK 3 router running firmware 7.1.0 build 1289. I have two SSIDs being broadcast - one at 5.0 GHz and the second at 2.4 GHz. All of the devices see neither network. I have tried uninstalling the Wemo iOS app and reinstalling. I have factory restored the devicess and the router. I have tried a different iOS device and an Android device. I have disabled network security. I have changed the channel that the 2.4 GHz network is broadcasted on. I set up a temporary network through the hotspot on my phone, connected the Wemo devices to that, and updated the firmware on them. I set-up an old Asus AC66RU router that I had and they are able to see the SSID broadcasted from that without issue.


Any thoughts?



Posts: 295
Registered: ‎08-08-2017

Re: WeMo Devices Cannot Detect Wifi SSID

Hi, grindtrace. Looks like you've done all the necessary troubleshooting, let's have our Support Team assist you further. Please send us an email at WemoCares@belkin.com along with the following details:

-Phone Number
-Location (State & Country)
-Community Username
-Link to this post for reference

Jo-Ann - 21744
WEMO Technical Support