WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 6
Registered: ‎01-31-2015

WeMo Link stuck in firmware updating...

After applying the latest firmware update the link did not finish applying the FW update. I let it continue over night and finally power cycled. Now when it comes up it still thinks it's updating. Any suggestions? iOS app version: Tried 1.13.5 and 1.14 Link FW: WeMo_WW_2.00.9896-PVT-OWRT-Link Thanks, Scott Hansen Seattle, WA
Moderator
Posts: 306
Registered: ‎06-29-2015

Re: WeMo Link stuck in firmware updating...

Hi, mojosea. Thank you for reaching out. Let's work on this together. What's the status light of the WEMO Link right now? Have you tried to force close the app and reboot your phone? If you haven't, please do so. We also suggest that you move the link closer to the router to avoid any interference when performing the firmware update. Update us with the results.

Dennis - 20702
WEMO Technical Support
Posts: 6
Registered: ‎01-31-2015

Re: WeMo Link stuck in firmware updating...

Dennis,

 

I was able to resolve my firmware update issue.  I worked through all the standard trouble-shooting steps (re-install app, reboot phone, use second phone with latest iOS, restart the link many times, etc.).  The step that actually allowed the link to complete the firware update and return to a healthy state was restarting my wireless router (even though it was running error free without any other know issues) and then power-cyling the link right after that.

 

So, I'm back in business.

 

Thanks,

 

-Mojo

Highlighted
Posts: 1
Registered: ‎12-05-2017

Re: WeMo Link stuck in firmware updating...

Having had the same situation, I did a reset on my WeMo Insight plug and it was fine after setting it up again.
Posts: 1
Registered: ‎02-20-2018

Re: WeMo Link stuck in firmware updating...

I have the same issue. I don't want to re-install my app, I don't want to lose all the rules that I have already created. What is the work around. 

 

I have four Wemo devices: Light Switch, Smart Plug, Mini Smart Plug and Maker. I gave okay to do firmware update on 2/17/18. When I returned to the Wemo app, the Light Switch and Smart Plug are stucked in "updating" mode. The Mini and Maker are working fine. I exited the app and restart the phone. The problem persists. Please advise the fix. Hopefully it does not require reinstall the app. I don't want to lose the rules that I have ready created. 

 

Thank you. 

Posts: 493
Registered: ‎08-04-2014

Re: WeMo Link stuck in firmware updating...

You shouldn't loose rules by reinstalling tha App - they are stored in the WeMos (and possibly theBelkin Cloud).

Posts: 1
Registered: ‎02-21-2018

Re: WeMo Link stuck in firmware updating...

Yufran's solution worked for me. I rebooted my router and after a while all my WeMo's stopped flashing orange and connected correctly. Now everything is working from the app. No other steps were necessary to get working. Thanks a bunch for the solution!
Posts: 14
Registered: ‎01-29-2018

Re: WeMo Link stuck in firmware updating...

Leaving the app & re-entering help get it over the stuck in downloading & installing stage for me.