WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 1
Registered: ‎11-19-2017

WeMo Mini Not Detected

Once again I have problems with my WeMo devices.  Maybe one day Belkin will actually put some effort into the software on these things.

 

Occasionally when my wireless network goes offline, my switches lose their connection and need to be factory reset before they'll connect again.  This time my WeMo Switch and WeMo Insight reconnected with no problems, but my WeMo Mini didn't.

At first, the WeMo Mini appeared to be connected to the network, but wasn't appearing in the WeMo app.  I used Fing and was able to see the WeMo Mini was online and connected to WiFi, but it wasn't responding to the WeMo app, IFTTT, Google Assistant, or any other linked systems.  I tried unplugging it and plugging back in, but it went to a flashing amber light.  I tried factory resetting it and using the WeMo app to set it up again, and it said it was connected, but then still shows Not Detected in the device list.

I reviewed some posts on this site and decided to check everything.  I reset the data on the WeMo app, set it to not remember my WiFi settings, checked my WiFi was on 2.4GHz Ch6, unplugged the Mini for about a minute to discharge completely, then factory reset it and set it up again.  Still having the same problem.  The WeMo app setup says it was successful, but the Mini itself never connects to the WiFi.  The Mini itself is only about 3 feet from the router, so it's definitely not a signal issue.

 

It was working fine until last night, so I have to assume it's a software issue.

Moderator
Posts: 306
Registered: ‎06-29-2015

Re: WeMo Mini Not Detected

Hi, Ceetch. Did you encounter an error message when you attempted to connect the Mini Switch to the network? We may need to have this checked by one of our Escalation Engineers for further diagnosis. Kindly e-mail us the following the details at WemoCares@belkin.com so we can open a ticket for you in our system:

 

  • Full Name:
  • Phone Number:
  • Location (state/country):
  • Community Username:
  • Link to this Community Thread (for our reference):
  • Wemo App Version:
  •  Firmware Version:

We look forward to hearing from you.

Dennis - 20702
WEMO Technical Support
Posts: 1
Registered: ‎11-30-2017

Re: WeMo Mini Not Detected

I have the same problem with my two wemo minis. Any help would be appreciated.
Posts: 1
Registered: ‎12-01-2017

Re: WeMo Mini Not Detected

I'm having the same problem as well for my WeMo Mini. Was this "not detected" related to the recent firmware update? Please advise.

Posts: 1
Registered: ‎12-01-2017

Re: WeMo Mini Not Detected

I have a similar problem.  After my WiFi goes offline, my WEMO Mini sometimes becomes unavailable and needs a factory reset to make it work again.

Moderator
Posts: 225
Registered: ‎01-05-2016

Re: WeMo Mini Not Detected

Hi, Guys,

 

Allow us to sort this out, how long have you been experiencing this challenge with your Wemo Mini? Did this work fine before? Whenever it's "not detected", what's the LED status of the Wemo Mini? 

 

Possible workarounds that you can try are the following:

 

-reboot

-make sure that the Wemo Mini is running on the latest FW

-place the Wemo Mini in an area with less interference

-if your device was recently updated, it'd be best to reset and reconfigure it

 

If these do not work, email us at WemoCares@belkin.com so we can have this further isolated. 

Ces-21490
WEMO Technical Support
Posts: 1
Registered: ‎12-14-2017

Re: WeMo Mini Not Detected

I am having this same problem. It is extremely frustrating to continually fail to even set up these allegedly “smart” devices. Since purchasing 2 Wemo Mini Smart plugs almost 3 months ago, I have still never once been able to successfully complete setup. I keep coming back to the setup once the frustration has dissipated to “try again,” or perhaps in hopes that a software update has addressed the issue since the last attempt.

At this point, I have tried all the discussed solutions (adjusting local network settings to create discrete dual-band SSIDs—defaulting to specified “required” channel on the 2.4GHz band, factory resetting the devices, deleting the app, choosing not to remember WiFi settings, attempting setup from multiple devices, etc.) and still have not had any success. Setup has failed at various steps along the way for different reasons but ultimately never completed. What is most infuriating is that, relative to an otherwise average consumer, I would consider myself extremely technologically adept. If after 3 months I still can’t set up a “smart plug,” I’m left to wonder who can?! Clearly something is missing. Please advise.
Moderator
Posts: 159
Registered: ‎08-09-2017

Re: WeMo Mini Not Detected

0xf8

Allow us to escalate your case to our 2nd Level Support Team for further diagnosis. Please email us the following details at WemoCares@belkin.com

 

Full Name:
Phone Number:
Location:
Community Username:
Link to this Community thread:

Pamela - 21733
WEMO Technical Support
Posts: 1
Registered: ‎12-23-2017

Re: WeMo Mini Not Detected

I am having this exact same issue. Tried from multiple devices, Android and iOS, etc etc but no dice.
Posts: 5
Registered: ‎12-22-2017

Re: WeMo Mini Not Detected

Same here. I purchased a couple of wemo mini and started using one of them and that worked great after setup. Some weeks later, I unboxed the 2nd wemo mini and successfully configured it. It showed up on the wemo app, and could be controlled from echo. However, after a few days, I noticed the switch blinking orange and couldn't be detected by wemo app or controlled by echo. I re-configured the wifi, and it behaved normal. Then the same happens the next day or two, while 3 other wemo switches are working fine. I re-configured the faulty mini unit again, and the same **bleep** happened again a few days later. I came here and read that many folks are having the same issue. This time, I followed the instructions for factory reset and re-configured it. Again, it works after reconfiguration but goes back to the same fault.

 

Now what? Can I still return/exchange this unit to Wemo? Switch to a different branch altogether?