WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 6
Registered: ‎01-06-2018

WeMo Switch F7C027 Won't Connect to Wifi After Reset

I don't have high hopes judging by the number of connection problem threads, but I thought I would give this a shot before I start replacing this equipment. 

 

I have the usual problems with my switches (F7C027) where I need to reset them everytime the power goes out or they are unplugged. This is unfortunet but I have been working around it hopeing it would get better. 

 

This time, after the power went out neither of my two switches would auto reconnect. OK normal. I tried reseting them and reconnecting them with the WEMO app but I get stuck every time at the WIFI password. 

 

"the WeMo App was unable to connect to 'my wifi network name' Please try re-entering your password."

 

I know my password is correct, and hasn't changed since the last time they were connected to the network.

 

I have tried:

resetting router

resetting switches too many times to count

installing the wemo app on another device and using that instead

"Forgetting" WeMo Switch Wifi in Android Wifi settings

"Forgetting" home wifi and reconnecting with phone

 

I also have a WEMO hard wired light switch, but that is working at the moment. 

 

Thanks!

Moderator
Posts: 69
Registered: ‎08-22-2017

Re: WeMo Switch F7C027 Won't Connect to Wifi After Reset

[ Edited ]

slowtype

Hi, there. Just to verify, what's the LED status of the Wemo switch when the issue occurs? For isolation, try to uninstall and reinstall the app. Make sure that it's on its latest version as well as the Wemo switch.

 

Hope this helps.

Nestor - 21974
WEMO Technical Support
Posts: 6
Registered: ‎01-06-2018

Re: WeMo Switch F7C027 Won't Connect to Wifi After Reset

Hey Nestor,

 

The Switch light is alternating between blue and orange. 

 

The app is a new install, I even installed a fresh version on a completely different device. 

 

I tried again today and still get the same error and request to re-enter my wifi password. 

 

Posts: 1
Registered: ‎01-18-2018

Re: WeMo Switch F7C027 Won't Connect to Wifi After Reset

Same problem here. As in exactly.

Moderator
Posts: 110
Registered: ‎08-22-2017

Re: WeMo Switch F7C027 Won't Connect to Wifi After Reset

Got all that noted, slowtypePlease email us at WemoCares@belkin.com along with your contact details, community username, and the link to this community thread for reference and we can have our Escalation Engineers assist you further.

Carl_S 21985
WEMO Technical Support
Moderator
Posts: 106
Registered: ‎08-08-2017

Re: WeMo Switch F7C027 Won't Connect to Wifi After Reset

[ Edited ]

@vdWens

 

We'll have this taken care of by our Escalation Engineers. Please follow the instructions given by 

Gerard-21724
Wemo Technical Support
Posts: 1
Registered: ‎01-28-2018

Re: WeMo Switch F7C027 Won't Connect to Wifi After Reset

Same here. Emailed and waiting for a response. @slowtype or @vdWens have you had any luck?
Posts: 1
Registered: ‎02-01-2018

Re: WeMo Switch F7C027 Won't Connect to Wifi After Reset

Same problem here but now with IOS-devices. Emailed and waiting for a response.

Posts: 6
Registered: ‎01-06-2018

Re: WeMo Switch F7C027 Won't Connect to Wifi After Reset

I worked with tech support but we were not able to resolve the problem. I was able to connect one of them to a second old router I had hanging around. But it was so much work. I had to use a tablet without a cellular connection and forget all the other networks in the wifi because it kept trying to use the wrong one durring setup. If I used my phone it would keep trying to use cellular durring setup. 

 

Anyway, I don't want to change the setting in my current router, they should work. It works fine for everything else in my house. It would also be a pain to reconnect every other connected device in my house with a different router setup. 

Posts: 6
Registered: ‎01-06-2018

Re: WeMo Switch F7C027 Won't Connect to Wifi After Reset

OK, I got them working tonight. I tihnk I have invested over 8 hours into this. But I am too stubbern to give up. 

 

I cobbled together a bunch of tricks that others on this forum have used.

 

-connected both the switches to my old router

-both needed a firmware update but no update was available

-turned off Remote Access and about 60 seconds later a firmware update window popped up

-within Edit Device menu Erased All Content and Settings for both devices

-changed my router channel to 11

-went through setup process (Remote Access was still off, not sure if that was significant) (didn't accept the password on the first try even though it was correct)

-Boom working

 

Notes: Tried to change the channel back to auto and the two switches could not be found in the app. Changed it back to 11 and they both immediatly came back online. My actual wall switch seems to work in channel 11 and auto. Also, in the past the switches worked find with the channel set to auto.

 

Way too much effort.