WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Posts: 10
Registered: ‎07-10-2014

Re: Wemo Bridge for Homekit

Following the directions on the link would remove ALL my WEMO devices from HomeKit, which is hardly the result that I am looking for. I want to be able to have all my devices show, and when I get the "Not Responding" on the tiles, it is for ALL my WEMO devices at the same time.


The only fix that works is if I reboot the bridge. The last time that I did a reboot was on Sunday and the devices are all showing up in HomeKit when I checked right now. Eventually they will all show up as "Not Responding" again, just a matter of time.

Posts: 152
Registered: ‎12-12-2017

Re: Wemo Bridge for Homekit

Please allow our Escalation Engineers to look into this further, sabresoft. They can also assist you in checking the latest available firmware of the Wemo Bridge. For us to proceed, please send an email to WemoCares@belkin.com with the following information
▪ your username and link to this thread for reference
▪ model numbers of the Wemo devices connected to Homekit through the Wemo Bridge

▪ model and iOS version of the handheld device you are using
▪ Home app version
▪ your name
▪ city/state
▪ phone number


Reil – 22071
Wemo Technical Support
Posts: 54
Registered: ‎02-01-2018

Re: Wemo Bridge for Homekit

Please explain this to me. How is it that when I’m on my own network many of my devices show has not connected; however, when I am off my network and using my LTE on my cell phone, all of my devices show connected and I’m able to control them. Basically when I’m home mini and might of my devices go off-line but when I’m away from the house I can control them all. Yes, my workaround is to turn off my Wi-Fi on my phone and then control my switches; however, this issue persists
Posts: 167
Registered: ‎12-12-2017

Re: Wemo Bridge for Homekit



What is the LED status of your Wemo devices? Is this the same when you're connected to a different wireless network? Please try to use a different mobile device and connect it to your home network and see if the devices will still show as not connected. You can also try to reboot or power cycle one of the Wemo devices for isolation, and make sure that your phone is connected to the 2.4 GHz network.


Jan - 22019
WEMO Technical Support
Posts: 54
Registered: ‎02-01-2018

Re: Wemo Bridge for Homekit

You are kidding, right! I am in IT and your request makes zero sense. I have two iPhones and I have done that probably 50 times with no success a while ago. I did that I ust on a hunch that something stupid was in the code. Rebooting and doing a power cycle is something I do all too often and is a failure in your application, your software, and your hardware. My Hues lightbulbs work perfectly with no issues whatsoever. If use offers wall switches or Hues starts to make them, then I will take yours and burn them in a pile of plastic smelly garbage. I have never had so much frustration with hardware as I have with this these Wemo switches and the WeMo minis. I just got them working and several just went off line. It trickles until they all have issues.

2.4 GHz... really? Of course, as I put together work around for many other posts, but these do not consistently work. I wonder if the code has memory leaks from poor garbage connections in the instances that called by hardware or software actions.

And rebooting my Wemo devices is a 50/50 chance that they’ll come back on the network in 1-3 days or not all. With rain storms and power outages or flickering, I’m doomed and will be unable to use them. Resetting the Wemo Bridge does work but erases all of my HomeKit automation and makes this pointless. I’m about to sell all of my emo products on ebay to invest in some other smart device.

I’ve worked with you guys 4 times now with very little success wasting 1/2 of my day off. I should bill you at my rate for the time I’ve been on phone, but I suspect you cannot afford that. It is really sad how inconsistent your development is and meager your support extends. I really think you need to move away from the WiFi mode and approach.
WEMO Maker Inventor
Posts: 1,796
Registered: ‎06-14-2014

Re: Wemo Bridge for Homekit

The real answer is that belkin made a few poor technical decisions early on.  I get the impression most if not all of the original designers are gone and the ones that are left have no idea how to fix things (I suspect most of the dev work is outsourced too).


Wemos use SSDP for discovery which typically will not cross network boundaries.  This is especially true between the 2.4GHz and 5GHz segments on routers (even though they're in the same subnet), and often SSDP will not work in mesh networks either.  (There's another issue there with how wemos select access points but if yours are not flashing amber that's not the issue).  If the wemo is not flashing amber then it's connected to your wifi and to the belkin cloud.


The belkin app itself, when it sees the phone is connected to your home SSID, will use SSDP to find the devices.  This will often fail if you're on the 5GHz band and the devices will be marked as non-responding.  If the belkin app sees a different SSID, or connects using data, it goes straight to the belkin cloud to control them (this is the root of the "no multi-location" problem).  As long as that cloud is up the wemos will be marked as active.  Result - no connection at home, success when remote.  It's also why renaming your 5GHz SSID can work - the belkin app goes into remote mode even when you're at home, so your device control makes a long round trip out of and back into your home via the belkin cloud servers.


The belkin homebride appears to be built from freeware that is fairly buggy - it doesn't stay up for very long (hence the advice to power cycle it often).  It's also pretty much abandon-ware so I would recommend anyone that hasn't bought it not to bother.


Reliable and secure (Belkin cloud-free) home automation and remote access:
Posts: 10
Registered: ‎07-10-2014

Re: Wemo Bridge for Homekit

Thanks Mike for a much more candid response than i have seen directly from WEMO folks. Their suggestion to delete non-responding devices was of no help because when I get "not responding" it is all the devices at once. I have a couple of spare WEMO Minis. Now I know what to do with one of them. Put it in to power the bridge and cycle the power either periodically, or at least when I get a hung bridge (as I can always see the devices in the app and could then reboot the bridge remotely).

Posts: 2
Registered: ‎11-01-2017

Wemo Bridge for Homekit - all devices not responding

When I first set it up, it worked beautifully with homekit.  Now, it only works if I connect my phone/device to the slow and not-very-secure 2.4Ghz part of my home network.  Devices in Wemo app still work, though with a significant delay.


I have a router with the 2.4Ghz that all the Wemo outlets, one switch, one slow cooker connect to which is direct into the router.  The Wemo bridge is also hard-wired connected to this network, directly into the router.


I have Google Wifi which is a separate 5Ghz more secure network that all other devices (phones, tablets, Apple TV) connect to.



Make sure your homekit hub (for me, the Apple TV) is on the SAME network (name) as the bridge.

Both of mine are now wire-connected directly into the router.

When I figured this out, I had to power-cycle the bridge and voilà!!


You see, I had lost the Apple TV remote so to be able to use the Apple TV remote app, I needed the Apple TV connected to the same wireless network as my phone.  That's when the homekit stopped working for me.  Though I had not understood this at the time.


Hope this helps a few people save a bit of time and a lot of aggravation.